Cannot save bookmark if more than one keyword is entered

RESOLVED INVALID

Status

()

Firefox for Android
General
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: cedric.houvenagel, Unassigned)

Tracking

49 Branch
Unspecified
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8798883 [details]
Screenshot_20161007-162523.png

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

1. open an url
2. bookmark it with star
3. click "options" to edit the bookmark
4. enter 1 keyword, then a comma, then a second keyword


Actual results:

the OK button becomes disabled (greyed). I cannot save my bookmark with 2 keywords.


Expected results:

the OK button stays enabled and allows me to save my bookmark with several keywords.
(Reporter)

Updated

a year ago
OS: Unspecified → Android
Keywords are a unique string without spaces or commas. Keywords are not the same as tags. https://support.mozilla.org/en-US/kb/how-search-from-address-bar
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
(Reporter)

Comment 2

a year ago
thank you Kevin for the explanation about keyword and tags. :)

so I think there is a mistake in the bookmark edition form on FF for Android.
The 3rd line of the form should ask for "tags" and not "keyword".

Let me explain :

If you read the article "how-search-from-address-bar", it says that "smart keyword" are only related to a specific "search field" in the bookmarked page. It is a very special use case that is "the user wants to create a shortcut for searching into a specific website".
When I'm creating a bookmark in FF for Android, I'm creating a "normal bookmark", not a "search field bookmark". So "smart keyword" should not be asked, but tags should.

I think I should create another report.
(Reporter)

Updated

a year ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 775672
Resolution: DUPLICATE → INVALID
You need to log in before you can comment on or make changes to this bug.