Closed Bug 1308526 Opened 3 years ago Closed 3 years ago

Intermittent dom/base/test/browser_bug1307747.js | Test timed out -

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Tracking Status
firefox50 --- unaffected
firefox51 --- unaffected
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: Gijs)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Flags: needinfo?(amarchesini)
this bug only happens on win7-vm pgo e10s.  Based on the most recent failure rates, this is in a high frequency bucket.

here is a clip from a failing log[0]: 
06:22:48     INFO - TEST-START | dom/base/test/browser_bug1307747.js
06:22:49     INFO - JavaScript error: chrome://mochikit/content/tests/BrowserTestUtils/content-task.js line 52 > eval, line 8: TypeError: can't access dead object
06:23:33     INFO - TEST-INFO | started process screenshot
06:23:33     INFO - TEST-INFO | screenshot: exit 0
06:23:33     INFO - Buffered messages logged at 06:22:48
06:23:33     INFO - Entering test bound test_initialize
06:23:33     INFO - Buffered messages logged at 06:22:49
06:23:33     INFO - TEST-PASS | dom/base/test/browser_bug1307747.js | We have a blob! - 
06:23:33     INFO - TEST-PASS | dom/base/test/browser_bug1307747.js | The size matches - 
06:23:33     INFO - Console message: [JavaScript Error: "The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol." {file: "http://mochi.test:8888/browser/dom/base/test/empty.html" line: 0}]
06:23:33     INFO - Console message: [JavaScript Error: "TypeError: can't access dead object" {file: "chrome://mochikit/content/tests/BrowserTestUtils/content-task.js line 52 > eval" line: 8}]
06:23:33     INFO - Buffered messages finished
06:23:33     INFO - TEST-UNEXPECTED-FAIL | dom/base/test/browser_bug1307747.js | Test timed out - 

in a passing log [1] there is no information other than the test passes in ~800ms:
INFO - TEST-OK | dom/base/test/browser_bug1307747.js | took 823ms

I suspect the root cause is the typeerror message:
06:23:33     INFO - Console message: [JavaScript Error: "TypeError: can't access dead object" {file: "chrome://mochikit/content/tests/BrowserTestUtils/content-task.js line 52 > eval" line: 8}]

:overholt- I am not sure if :baku lost track of this, or is on pto or another project- maybe you can help find someone to look into this bug?


[0] https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-win32-pgo/1482924603/autoland_win7_vm_test_pgo-mochitest-e10s-browser-chrome-1-bm129-tests1-windows-build280.txt.gz
[1] https://archive.mozilla.org/pub/firefox/tinderbox-builds/autoland-win32-pgo/1482903011/autoland_win7_vm_test_pgo-mochitest-e10s-browser-chrome-1-bm129-tests1-windows-build279.txt.gz
Flags: needinfo?(overholt)
Pretty sure this is broken because we don't wait for the page to load in the tab we're adding before spawning a ContentTask in it, making the content task race with the load of the page we requested, which then means we talk to dead things and time out. This can be solved by using openNewForegroundTab from BrowserTestUtils and yielding for it (which will wait for the load). I should have a patch soon, need to rebuild after the holidays.
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(overholt)
Flags: needinfo?(amarchesini)
Comment on attachment 8823256 [details]
Bug 1308526 - fix waiting for the test page to load before trying to use it,

https://reviewboard.mozilla.org/r/101802/#review102506

Net improvement.
Attachment #8823256 - Flags: review+
Attachment #8823256 - Flags: review?(amarchesini)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/266b78fa3d41
fix waiting for the test page to load before trying to use it, r=mikedeboer
Keywords: leave-open
I'll look at this end of today / tomorrow and see if we're in the clear here.
Flags: needinfo?(gijskruitbosch+bugs)
No hits on trunk trees yesterday or today, and only 1 on the day this landed (before it landed) - the intermittent is dead, long live the intermittent. No, wait, that other thing.
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Flags: needinfo?(gijskruitbosch+bugs)
Keywords: leave-open
Resolution: --- → FIXED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.