bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Crash in mozilla::MozPromise<T>::ChainTo

RESOLVED DUPLICATE of bug 1308078

Status

()

Core
Audio/Video: Playback
P1
critical
RESOLVED DUPLICATE of bug 1308078
2 years ago
2 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({crash})

Trunk
Unspecified
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(firefox49 affected, firefox52 affected)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-167e46eb-7542-4095-a863-4e4542161007.
=============================================================

Seen while looking at nightly crash stats. Crash affects Linux and Mac only (at least with this signature): http://bit.ly/2dAiLYh

On 52 the crashes started with 20161006030208. Currently ~113 crashes on Linux and Mac.

Comment 1

2 years ago
Since the crash address is a small offset from 0x0, this looks like mMethodCall->Invoke(...) returns a null pointer: https://hg.mozilla.org/mozilla-central/annotate/777fb63db8de/xpcom/threads/MozPromise.h#l962

Comment 3

2 years ago
N.B. I'm basing this suggestion on my own crash report which occurred after pressing play on a Facebook video, seeing it not actually load anything, and seeking around in it a few times to try to get it to play (also switching in an out of the HD mode): https://crash-stats.mozilla.com/report/index/9ca9f1d0-eea2-4676-8dd4-1b6e62161008
Component: Audio/Video → Audio/Video: Playback
(In reply to Josh Matthews [:jdm] from comment #2)
> One possibility: perhaps we're ending up in
> https://dxr.mozilla.org/mozilla-central/rev/
> a835589ae0c63a2d91be150d80b5fc600e44b447/dom/media/MediaDecoderStateMachine.
> cpp#224 ?

I share your opinion in bug 1308603 comment 2. Let's see if the patch can give more debugging information.
See Also: → bug 1308603
Duplicate of this bug: 1309623
Crash volume for signature 'mozilla::MozPromise<T>::ChainTo':
 - nightly (version 52): 1267 crashes from 2016-09-19.
 - aurora  (version 51): 0 crashes from 2016-09-19.
 - beta    (version 50): 0 crashes from 2016-09-20.
 - release (version 49): 11 crashes from 2016-09-05.
 - esr     (version 45): 0 crashes from 2016-07-25.

Crash volume on the last weeks (Week N is from 10-17 to 10-23):
            W. N-1  W. N-2  W. N-3  W. N-4
 - nightly     788     428       0       0
 - aurora        0       0       0       0
 - beta          0       0       0       0
 - release       2       1       1       7
 - esr           0       0       0       0

Affected platforms: Windows, Mac OS X, Linux

Crash rank on the last 7 days:
           Browser   Content     Plugin
 - nightly #31       #10
 - aurora
 - beta
 - release #32441    #3867
 - esr
status-firefox49: --- → affected
Priority: -- → P1
(In reply to JW Wang [:jwwang] [:jw_wang] from comment #4)
> (In reply to Josh Matthews [:jdm] from comment #2) ...
> I share your opinion in bug 1308603 comment 2. Let's see if the patch can
> give more debugging information.

This signature's reign of terror seems to end after build 20161012030211, so based on bug 1308603 comment 21 by JW, I'd say that bug 1308078 also fixed this one here.
(Or maybe it was something else coincidentally close, but in any case this bug can be closed.)

JW, would you agree?
Flags: needinfo?(jwwang)
Can't agree with you any more. :) Let's close this bug.
Flags: needinfo?(jwwang)
Thank you.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1308078
You need to log in before you can comment on or make changes to this bug.