Status

()

VERIFIED DUPLICATE of bug 57555
17 years ago
17 years ago

People

(Reporter: Anders.Grund, Unassigned)

Tracking

Trunk
Sun
SunOS
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
In a mail view/headers/all  does not show OS version on Solaris

It Only displays SunOS (same does mozilla -version se below)

Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:0.9.9) Gecko/20020311, build 2002031103

Minor stuff but anyway! :-)

/Anders

Comment 1

17 years ago
I don't think that this a valid bug because SunOS is another name for Solaris.
Solaris 7 can also correctly be called SunOS 5.7.  In fact, uname -a (which may
be where mozilla gets the OS info) calls my Soalris 7 box:
SunOS gordo 5.7 Generic_106541-19 sun4u sparc SUNW,Ultra-5_10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID

Comment 2

17 years ago
you missed the point.

windows reports w95, w98, wME, nt4, w2k, wXP.

solaris just reports solaris...  reporter: can you start a thread in npm.unix 
or npm.netlib asking about this?

also, what do nc4 and ie solaris do?
Status: RESOLVED → UNCONFIRMED
Component: Browser-General → Networking
Resolution: INVALID → ---
(Reporter)

Comment 3

17 years ago
I don't think so, but i mentioned News headers not mail headers.
The X-Mailer News header to be specifik 
As far as i know in all News reader i have used you can always se the OS version
And not only the OS itself.

Here is what some NS4 version have in the X-Mailer field.

Depending on from which workstation you used NS and send news message this is
how the News header looks. 
Mozilla 4.77C-CCK-MCD [en] (X11; U; SunOS 5.7 sun4
u)

Well in your first message you contradict yourself.
The OS string from Solaris 8 is SunOS 5.8, so you have a truncated output from
uname -a or something similar.

And besides, kind of weird if you have the architecture sun4u but not OS version

IE does not have a News reader,

Sorry that i did not mention that it is in the News header from the start

Mozilla 4.79C-CCK-MCD [en] (X11; U; SunOS 5.8 sun4u)


 
Mozilla 4.79C-CCK-MCD [en] (X11; U; SunOS 5.8 sun4u

Mozilla 4.76C-CCK-MCD [en] (X11; U; SunOS 5.7 sun4u)

/Anders
Summary: Mail header bugg → News header bugg

Comment 4

17 years ago
reporter: the correct header for the future is User-Agent, so if you could get 
ie solaris's browser agent, i'd still appreciate it. i'll work on this with one 
of my rewrites.
Assignee: asa → new-network-bugs
QA Contact: doronr → benc

Comment 5

17 years ago
timeless: take a look at bug 57555 and
http://www.mozilla.org/build/revised-user-agent-strings.html before you work on
this.  It looks like the current setup is the policy - ie that we're not
revealing OS versions on Unix.

I'll leave this unconfirmed, but its probably either a dupe of 57555 or invalid.

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 57555 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.