error occurred while processing 'resolveLocation: CompileError: at offset 0

RESOLVED WORKSFORME

Status

P2
major
RESOLVED WORKSFORME
2 years ago
2 months ago

People

(Reporter: kasper93, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Reload http://player.twitch.tv/?channel=<some_live_channel> with dev tools open.

In browser console error shows up (form resource://devtools/server/main.js:1611): 

error occurred while processing 'resolveLocation: CompileError: at offset 0: failed to match magic number
Stack: isHiddenSource@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/utils/TabSources.js:822:3
TabSources/this.allowSource@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/utils/TabSources.js:32:13
TabSources.prototype.source@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/utils/TabSources.js:120:12
TabSources.prototype.createNonSourceMappedActor@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/utils/TabSources.js:351:12
onResolveLocation@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/webbrowser.js:2082:28
onPacket@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/main.js:1748:15
ChildDebuggerTransport.prototype.receiveMessage@resource://gre/modules/commonjs/to

After that dev tools cannot be closed. Looks like all panels are destroyed (TypeError: webconsolePanel is null) when changing tabs. But debugger one is still alive so I assume it prevents to close dev tools. 

It is easily reproducible so you will figure it out in no time :)

Regards

Comment 1

2 years ago
WFM in 52.0a1 (2016-11-01) (32-bit)
Can't seem to reproduce in Nightly but I can see it breaking in Release; but not crashing.  Reopen this if the error persists.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Priority: -- → P2
Resolution: --- → FIXED

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.