Lightning about version 4.7 is un-installed automaticly several times

RESOLVED WONTFIX

Status

Calendar
General
RESOLVED WONTFIX
a year ago
a year ago

People

(Reporter: Rob Frings, Unassigned)

Tracking

Lightning 4.7
x86_64
Windows 10

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

When starting thunderbird, lightning is often not available. Looking in add-ons, it often tells it is not compatible (I don't know the exact syntax) with this version of thunderbird (45)
Installing lightning again by using the same file: lightning-4.7-sm+tb-windows.xpi results in a message I have to restart thunderbird again.
Clicking restart causes thunderbird to quit. I have to start thunderbird manually again.
For a few days it works. Then the not compatible message appears again and I have to repeat installing again. 
I'm glad all old data is used then.



Actual results:

Lightning is faded out in add-ons called not compatible with this version.


Expected results:

If not compatible, it should update, but that is not the issue here.
It should start with starting thunderbird ALLWAYS.
(Reporter)

Updated

a year ago
Severity: normal → major
OS: Unspecified → Windows 10
Priority: -- → P3
Hardware: Unspecified → x86_64

Comment 1

a year ago
Can you tell us more about your setup? Every detail may help.

E.g. Where is your profile located (logically and physically)? Is this with a local or roaming Windows profile? Is the Tb profile location in scope of a backup? If so, what backup mechanism/software is used? Is there a timely coincidence of backup/restore processes or Windows profile (re-)sync?
Flags: needinfo?(fringsrs)
(Reporter)

Comment 2

a year ago
I try to provide you with the asked info.
The profiles.ini files:
[General]
StartWithLastProfile=1

[Profile0]
Name=default
IsRelative=0
Path=D:\Dropbox\Data Thunderbird\Profiles\Nieuw.default

Dropbox is used to synchronise only the next folders:
D:\Dropbox\Data Thunderbird\Profiles\nieuw.default\calendar-data
D:\Dropbox\Data Thunderbird\Profiles\nieuw.default\crashes
D:\Dropbox\Data Thunderbird\Profiles\nieuw.default\datareporting
D:\Dropbox\Data Thunderbird\Profiles\nieuw.default\extensions
D:\Dropbox\Data Thunderbird\Profiles\nieuw.default\Mail
D:\Dropbox\Data Thunderbird\Profiles\nieuw.default\s3menuwizard
D:\Dropbox\Data Thunderbird\Profiles\nieuw.default\webapps
D:\Dropbox\Data Thunderbird\Profiles\nieuw.default

Maybe I can reduce the number of folders.
I want to have the address-books, the add-ons and the pop mail synchronised for 2 computers.
But I don't know witch folders I don't need to synchronise to archive my goal.

Other add-ons I use are: Identity Chooser, Lightning, Lightning Nightly Updater (Unofficial), Lightning Reminder Left Buttons, LightningButton, Manually Sort Folders and Remove Duplicate Messages.

If you need more info, let know.

Comment 3

a year ago
(In reply to Rob Frings from comment #2)

> I want to have the address-books, the add-ons and the pop mail synchronised
> for 2 computers.
> But I don't know witch folders I don't need to synchronise to archive my
> goal.
> 
> Other add-ons I use are: Identity Chooser, Lightning, Lightning Nightly
> Updater (Unofficial), Lightning Reminder Left Buttons, LightningButton,
> Manually Sort Folders and Remove Duplicate Messages.

Lightning is a binary addon that cannot be shared accross different platforms (Windows/Linux/OS X), target architecture (32/64 bit) or TB versions. Is that case for you here?

The Lightning Nightly Updater does let me assume you're at least trying to share accross versions as your report is for the current ESR version and not a Daily.

If this is a cross version sync issue here, at least exclude D:\Dropbox\Data Thunderbird\Profiles\nieuw.default\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103} from being synced (and syncing it is pointless, as the appropriate version of Lightning is distributed by TB anyway).
(Reporter)

Comment 4

a year ago
It is not a cross version. So excluding from sync D:\Dropbox\Data Thunderbird\Profiles\nieuw.default\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103} is not needed. I even don't know how to exclude it from being sync.

Does Lightning sync its data automatic? Or have to make specific settings?

Comment 5

a year ago
Excluding the extension directory from syncing is _strictly_ recommended, regardless whether you use it cross platform or not. We had different sync issues with roaming profiles involved and we currently have no capacity to dig further in that area, so if excluding from sync resolves the issue for you, please do so.

Especially as you have no benefit from syncing, because Lightning is shipped with your copy of TB anyway, so you're up to date anyway.

Calendar data are not stored in the extension folder but in calendar-data folder of the TB profile or on the calendar servers (if you are using serverside calendars).

Regarding dropbox sync configuration, I cannot be of any help.
If two machines, possibly with different Thunderbird versions (even in the short time between upgrades) are accessing the same profile, I'm not surprised there are issues with Lightning compatibility. Running profiles shared between computers over a sync mechanism like Dropbox is not supported, therefore I'd prefer to close this bug. Also, I don't believe this would be an issue specific to Lightning, but generally to how add-ons work in Mozilla products.

If you are having the same problem when accessing from one computer and the profile not being on dropbox, we can happily reopen. Please also look into selective sync: https://www.dropbox.com/en/help/175
Severity: major → normal
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(fringsrs)
Priority: P3 → --
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.