Closed Bug 1308740 Opened 3 years ago Closed 3 years ago

Firefox Setup 49.0.1.exe metadata is EMPTY!

Categories

(Firefox :: Installer, defect)

31 Branch
Unspecified
Windows
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 53
Tracking Status
firefox50 --- wontfix
firefox51 --- wontfix
firefox52 --- wontfix
firefox53 --- fixed

People

(Reporter: dv5678, Assigned: robert.strong.bugs)

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20161007004004

Steps to reproduce:

1) Visit https://www.mozilla.org/en-US/firefox/all/
2) Download Windows or Windows 64. (Probably any language.) (I only tested with English-US and Windows.)
3) Right-click on "Firefox Setup 49.0.1.exe" and then Properties.
4) Click on Details.


Actual results:

File description is BLANK.
File version is 4.42.0.0
Product name is BLANK.
Product version is BLANK.
Copyright is BLANK.
Language is BLANK.
[Sorry if this delivery and packaging and issue might not belong HERE. (This report belongs somewhere, even if no place has been provided.)]


Expected results:

There are 91 x 5 = 455 versions on that page. (91 win32 and 91 win64.)
Metadata in each file must declare its Product name. (e.g., Firefox 32-bit)
Metadata in each file must declare its Product version. (e.g., 49.0.1)
Metadata in each file must declare its Copyright. (e.g., 2016, Mozilla Foundation)
Metadata in each file must declare its Language. (e.g., English (US))
Valid metadata (except for product version always 4.42) were entered until version 30.0 (20140606). After that there is only a digital signature, no metadata telling WHAT the file IS.
Component: Untriaged → Other
Product: Firefox → Release Engineering
QA Contact: mshal
Version: 49 Branch → ---
pushlog(m-c)
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e71ed4135461&tochange=7fe3ee0cf8be
Status: UNCONFIRMED → NEW
Component: Other → Installer
Ever confirmed: true
Keywords: regression
Product: Release Engineering → Firefox
QA Contact: mshal
Version: --- → 31 Branch
OS: Unspecified → Windows
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235835
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → robert.strong.bugs
Status: REOPENED → ASSIGNED
Attached patch patchSplinter Review
This restores the old metadata to the 7zSD.sfx file using reshacker.


1 VERSIONINFO
FILEVERSION 4,42,0,0
PRODUCTVERSION 4,42,0,0
FILEOS 0x40004
FILETYPE 0x1
{
BLOCK "StringFileInfo"
{
	BLOCK "040904B0"
	{
		VALUE "CompanyName", "Mozilla"
		VALUE "FileDescription", "Firefox"
		VALUE "FileVersion", "4.42"
		VALUE "InternalName", "7zS.sfx"
		VALUE "LegalCopyright", "Mozilla"
		VALUE "OriginalFilename", "7zS.sfx.exe"
		VALUE "ProductName", "Firefox"
		VALUE "ProductVersion", "4.42"
	}
}

BLOCK "VarFileInfo"
{
	VALUE "Translation", 0x0409 0x04B0
}
}
Attachment #8813513 - Flags: review?(mhowell)
I also changed the minimum OS string to Windows 7 in 7zSD.sfx. This is a best effort notification for Win2K systems as part of the fix for bug 792106.
Attachment #8813536 - Flags: review?(mhowell)
Attachment #8813536 - Flags: review?(mhowell) → review+
Comment on attachment 8813513 [details] [diff] [review]
patch

Review of attachment 8813513 [details] [diff] [review]:
-----------------------------------------------------------------

I feel like this makes the version number misleading; it reads as "Mozilla Firefox 4.42", which doesn't make sense, and I don't think anyone would notice the InteralName and figure out what it means. Changing the FileDescription to something more specific would help.
Attachment #8813513 - Flags: review?(mhowell) → review-
I went with reverting to the previous values so it wouldn't be necessary to get the new value approved. I'd prefer a change to be done in a separate bug.
Comment on attachment 8813513 [details] [diff] [review]
patch

Given comment #6 do you still want to re-add this and change the value or are you ok with changing the value in another bug?
Attachment #8813513 - Flags: review- → review?(mhowell)
Comment on attachment 8813513 [details] [diff] [review]
patch

Review of attachment 8813513 [details] [diff] [review]:
-----------------------------------------------------------------

I'm okay with changing it in a separate bug.
Attachment #8813513 - Flags: review?(mhowell) → review+
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/60fc8a86c409
revert the 7-Zip stub metadata to the previous values. r=mhowell
https://hg.mozilla.org/integration/mozilla-inbound/rev/7b26df64ffa8
change the minimum support OS string to Windows 7 in the modified 7-Zip stub source. r=mhowell
https://hg.mozilla.org/mozilla-central/rev/60fc8a86c409
https://hg.mozilla.org/mozilla-central/rev/7b26df64ffa8
Status: ASSIGNED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Comment on attachment 8819373 [details] [diff] [review]
change the minimum support OS string to Windows 7 in the modified 7-Zip stub source.

(git bz fail, apologies)
Attachment #8819373 - Attachment is obsolete: true
Is this worth backporting to Aurora/Beta?
Flags: needinfo?(robert.strong.bugs)
I don't think it is but that would be better asked of mhowell since he owns the installer now.
Flags: needinfo?(robert.strong.bugs) → needinfo?(mhowell)
I agree, this is too minor to merit backporting.
Flags: needinfo?(mhowell)
You need to log in before you can comment on or make changes to this bug.