Thunderbird Help | About | Release Notes shows wrong information (Firefox release notes). Needs redirection.

RESOLVED DUPLICATE of bug 1329514

Status

Thunderbird
General
RESOLVED DUPLICATE of bug 1329514
2 years ago
a year ago

People

(Reporter: Lu Wei, Unassigned)

Tracking

49 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

Thunderbird popped out a notification that 50.0 beta 1 is available, and I click the "view more information about this update"


Actual results:

Firefox opens to https://www.mozilla.org/en-US/thunderbird/50.0/releasenotes/ , but "oops" information appeared to tell me the information does not exist.


Expected results:

It should show release notes of Thunderbird 50.0 beta 1.
(Reporter)

Comment 1

2 years ago
I think it's better that the release notes or whatsnew info be displayed right on the pop-up notification, to skip the additional step. And the download size too.
Component: Thunderbird → General
Product: www.mozilla.org → Thunderbird
Summary: link to Thunderbird release notes not found → Thunderbird update notification be revised
Version: Production → 49 Branch

Comment 2

2 years ago
It's because the release notes haven't been created yet.
I failed to remind jorg
Flags: needinfo?(jorgk)

Comment 3

2 years ago
TB 50 beta 1 available?? I saw nothing on tb-drivers, last message was:
Tagging started for Thunderbird 50.0b1 build2
Flags: needinfo?(jorgk)
(Reporter)

Comment 4

2 years ago
OK, since I cannot edit the bug description, should I raise another bug for the request in comment 1 that the "what's new" info be displayed right in the notification window?

Comment 5

2 years ago
I switched https://www.mozilla.org/en-US/thunderbird/50.0beta/releasenotes/ live, but the system usually needs a few hours before this becomes publicly visible.

Comment 6

2 years ago
Jorg, thanks for putting up the notes


(In reply to Jorg K (GMT+2) from comment #3)
> TB 50 beta 1 available?? I saw nothing on tb-drivers, last message was:
> Tagging started for Thunderbird 50.0b1 build2

If you didn't get any emails after that, what should have come next is a series of email from release-automation-notifications-thunderbird@mozilla.org - which means you are not on the release automation list. If you want you can subscribe at
    https://mail.mozilla.org/listinfo/release-automation-notifications-thunderbird

Comment 7

2 years ago
Putting up the notes is one thing, but actually seeing them is another :-((

In TB 50 beta, if you try to access the notes from the "About Thunderbird" panel, you get to
https://www.mozilla.org/en-US/firefox/50.0beta/releasenotes/

Help > Release Notes is a 404 at
https://www.mozilla.org/en-US/thunderbird/nightly/releasenotes/?uri=/thunderbird/releasenotes/&locale=en-US&version=50.0&os=WINNT&buildid=20161007134619

So some of the redirection magic isn't working yet.

> If you didn't get any emails after that, ...
Usually I get e-mail from Joe and then some e-mail with "releng, please push" on tb-drivers. The latter has just arrived now.

Comment 8

2 years ago
Now it shows not Thunderbird release notes, but "See what’s new in Firefox!"
Summary: Thunderbird update notification be revised → Thunderbird Help | About | Release Notes shows wrong information

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Thunderbird Help | About | Release Notes shows wrong information → Thunderbird Help | About | Release Notes shows wrong information (Firefox What's New). Needs redirection.

Comment 9

2 years ago
Clarification to comment 8, it's showing release notes for Firefox, but the heading is "What's New"

Help | Release Notes gets us to https://www.mozilla.org/en-US/thunderbird/50.0beta/releasenotes/?uri=/thunderbird/releasenotes/&locale=en-US&version=50.0&os=WINNT&buildid=20161017040505 ... which is what Help | About | Release Notes should hit
Summary: Thunderbird Help | About | Release Notes shows wrong information (Firefox What's New). Needs redirection. → Thunderbird Help | About | Release Notes shows wrong information (Firefox release notes). Needs redirection.
(Reporter)

Comment 11

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #10)
> bug 1329514?

Yes they are similar bugs and should be treated together. 
It's strange that "Help->Release notes" and "About Thunderbird -> Release notes" point to different places.

Updated

a year ago
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1329514
You need to log in before you can comment on or make changes to this bug.