Response tab of dev tools shows rubbish when Brotli is used

RESOLVED DUPLICATE of bug 1260403

Status

RESOLVED DUPLICATE of bug 1260403
2 years ago
5 months ago

People

(Reporter: c4609174, Unassigned)

Tracking

51 Branch

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8799233 [details]
ResponseRubbish.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20161008004004

Steps to reproduce:

1. Visit a site using the Brotli compression algorithm. E.g. https://scotthelme.co.uk/ (source: https://scotthelme.co.uk/brotli-compression/)
2. Open the dev tools, go to network, click on a request.
3. Choose the tab response.


Actual results:

Only rubbish is shown instead of the actual data. Maybe this is the raw uncompressed data. :)
See attached screenshot.


Expected results:

Show uncompressed data as you show it when Brotli is not used.
(Reporter)

Updated

2 years ago
Has STR: --- → yes
Component: Untriaged → Developer Tools: Netmonitor
(Reporter)

Comment 1

2 years ago
> Maybe this is the raw uncompressed data. :)

Of course I meant: "Maybe this is the raw compressed data. :)"

Comment 2

2 years ago
Looks like a duplicate of bug 1260403

(Having the same issue here with ff51.0a2 buildid 20161009004008)
(Reporter)

Comment 3

2 years ago
Yes the other bug seems to be about the same.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1260403

Updated

5 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.