Error overwriting a file - file could not be saved because you do not have the proper permissions

UNCONFIRMED
Unassigned

Status

()

Toolkit
General
UNCONFIRMED
a year ago
a year ago

People

(Reporter: GCRaistlin, Unassigned)

Tracking

48 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8799264 [details]
fb2k.png

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:48.0) Gecko/20100101 Firefox/48.0
Build ID: 20160823121617

Steps to reproduce:

I clicked on a link that points to a file. FF asked me where I want to save a file to. I selected a folder on a network drive that already contains a file with the same name. FF asked me if I want to overwrite an existing file. I answered Yes.


Actual results:

The message window appeared (see attach). The existing file (the one that I wanted to overwrite) was deleted. The new file isn't saved. If I try to save it again to the same folder it is being saved successfully.


Expected results:

The existing file should be overwritten by a new one.

Updated

a year ago
Component: Untriaged → General
Product: Firefox → Toolkit

Updated

a year ago
QA Whiteboard: [bugday-20161010]

Comment 1

a year ago
Is it reproducible when saving the file on a local HDD containing the same file?
Flags: needinfo?(gcraistlin)
(Reporter)

Comment 2

a year ago
No. What is more, after successful saving I'm able to overwrite the file as many times as I wish - but only before FF restart. Also, the issue is unstable - sometimes (but rarely) it can't be reproduced.
I believe I found the reason - it's Spider Guard, a component of DrWeb anti-virus (drweb.com). If it is disabled the issue isn't reproducible.

Comment 3

a year ago
Could you report the bug to DrWeb support, please.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(gcraistlin)
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

a year ago
I don't think that it's a DrWeb fault. IE could overwrite files under the same conditions just fine.
(Reporter)

Updated

a year ago
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 5

a year ago
Did it use to work with previous versions of FF like FF48 or 45?

If yes, could you download the tool mozregression to narrow down a regression in FF49(or older).
See http://mozilla.github.io/mozregression/ for details to use it.
Run the command 'mozregression --good=48 (or any version working)' then copy here the final pushlog.
Flags: needinfo?(gcraistlin)
(Reporter)

Comment 6

a year ago
No, the behaviour of previous versions was the same. I was just too lazy to report this before.
(Reporter)

Comment 7

a year ago
HideTab extension was guilty of the issue. Sorry for bothering guys.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year agoa year ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

a year ago
No I was wrong. I have reproduced the bug in 48.0.2 with all add-ons disabled and also in a just created clean profile. Also, I have reproduced it in portable versions 30.0, 40.0 and 49.0.2.

The ability to reproduce depends on the size of the file. It is pretty reproducible with 80KB+ file (http://www.nirsoft.net/utils/cports.zip on http://www.nirsoft.net/utils/cports.html#DownloadLinks) - at least 1 time of 3. IE still successfully overwrites the same file 10 times of 10.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(gcraistlin)
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.