Talkback: Third of Top Ten Incidents in M9

VERIFIED DUPLICATE of bug 10996

Status

()

Core
XUL
P3
major
VERIFIED DUPLICATE of bug 10996
19 years ago
10 years ago

People

(Reporter: Shiva Thirumazhusai, Assigned: Chris McAfee)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Here is the Stack Trace
Incident ID 13153344
nsCSSFrameConstructor::ConstructTableGroupFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 1272]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3038]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3983]
nsCSSFrameConstructor::TableProcessChild
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 1713]
nsCSSFrameConstructor::TableProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 1687]
nsCSSFrameConstructor::ConstructTableGroupFrameOnly
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 1354]
nsCSSFrameConstructor::ConstructTableGroupFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 1237]
nsCSSFrameConstructor::ConstructTableFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 982]
nsCSSFrameConstructor::ConstructXULFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3055]
nsCSSFrameConstructor::ConstructFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 3983]
nsCSSFrameConstructor::ProcessChildren
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 774]
nsCSSFrameConstructor::ConstructDocElementFrame
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 2082]
nsCSSFrameConstructor::ContentInserted
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSFrameConstructor.cpp,
line 4581]
StyleSetImpl::ContentInserted
[d:\builds\seamonkey\mozilla\layout\base\src\nsStyleSet.cpp, line 799]
PresShell::InitialReflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 780]
XULDocumentImpl::StartLayout
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 4077]
XULDocumentImpl::EndLoad
[d:\builds\seamonkey\mozilla\rdf\content\src\nsXULDocument.cpp, line 1897]
XULContentSinkImpl::DidBuildModel
[d:\builds\seamonkey\mozilla\rdf\datasource\src\nsXULContentSink.cpp, line
550]
CWellFormedDTD::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsWellFormedDTD.cpp, line 308]
nsParser::DidBuildModel
[d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp, line 530]
nsParser::ResumeParse [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 893]
nsParser::EnableParser [d:\builds\seamonkey\mozilla\htmlparser\src\nsParser.cpp,
line 620]
CSSLoaderImpl::Cleanup
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 646]
CSSLoaderImpl::SheetComplete
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 716]
CSSLoaderImpl::ParseSheet
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 751]
CSSLoaderImpl::DidLoadStyle
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 785]
DoneLoadingStyle
[d:\builds\seamonkey\mozilla\layout\html\style\src\nsCSSLoader.cpp, line 588]
nsUnicharStreamLoader::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\util\src\nsNetStreamLoader.cpp, line
163]
nsChannelListener::OnStopRequest
[d:\builds\seamonkey\mozilla\webshell\src\nsDocLoader.cpp, line 2416]
nsFileChannel::OnStopRequest
[d:\builds\seamonkey\mozilla\netwerk\protocol\file\src\nsFileChannel.cpp, line
794]
nsOnStopRequestEvent::HandleEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp,
line 274]
nsStreamListenerEvent::HandlePLEvent
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp,
line 150]
PL_HandleEvent [plevent.c, line 510]
PL_ProcessPendingEvents [plevent.c, line 471]
_md_EventReceiverProc [plevent.c, line 936]
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x242e7 (0xbff942e7)
0x00638bfe


Some of the User Comments

- I went to the tri-state button test page
  under the Debug menu and I got a good
  old windows illegal operation box

- I ran the XPToolkit "tree" debug command

- i went to the thee demo on the XP
  Toolkit options in this milestone and it
  crashed

- had just looked at tri-state checkbox

- Went to Debug, XPToolkit, Tree.

Updated

19 years ago
Assignee: peterl → hyatt
Component: Style System → XUL

Comment 1

19 years ago
Looks like a tree control problem

Updated

19 years ago
Assignee: hyatt → mcafee

Comment 2

19 years ago
It's a dup of a bug mcafee has.
(Reporter)

Updated

19 years ago
Depends on: 7919

Updated

19 years ago
No longer depends on: 7919

Updated

19 years ago
Blocks: 7919
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
Target Milestone: M1
(Assignee)

Comment 3

19 years ago
dup.


*** This bug has been marked as a duplicate of 10966 ***

Updated

19 years ago
QA Contact: chrisd → ckritzer

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Marking VERIFIED DUPLICATE per macafee's comments.

Comment 5

19 years ago
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL

Comment 6

19 years ago
Reopening to fix typo in DUP -- bug 10996 is also about trees, bug 10966 is not.
Status: VERIFIED → REOPENED

Comment 7

19 years ago
This is a DUP of bug 10996, "tree test crashes", not bug 10966, 
"[FEATURE] Windows 98 desktop integration".

*** This bug has been marked as a duplicate of 10996 ***
Status: REOPENED → RESOLVED
Last Resolved: 19 years ago19 years ago

Comment 8

18 years ago
Marking VERIFIED DUPLICATE on:
- Linux6 2000-03-01-13 Commercial build
- MacOS9 2000-03-01-13 Commercial build
- Win98 2000-03-01-16 Commercial build
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: ckritzer → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.