Add "NS_MRE_DIR" Directory Service Key

RESOLVED DUPLICATE of bug 130877

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 130877
17 years ago
16 years ago

People

(Reporter: Chak Nanga, Assigned: Chak Nanga)

Tracking

Trunk
mozilla1.1alpha
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

17 years ago
We need to add a well known directory service key named "NS_MRE_DIR" to the
existing dir service keys.

Embedding applications using an MRE are supposed to provide the location of the
MRE  they're trying to run against via their FileLocationProvider implementation. 

The changes to XPCOM's DirServiceProvider include:
   - Defining the string, #define of NS_MRE_DIR
   - Providing a default impl for this atom (in case the application's not using
an MRE)
(Assignee)

Updated

17 years ago
Blocks: 129573

Comment 1

17 years ago
pushing milestone out based on requirement feedback from Chak and Jud.
Target Milestone: --- → mozilla1.1alpha
(Assignee)

Comment 2

16 years ago
This is a dup of 130877

*** This bug has been marked as a duplicate of 130877 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.