anchor tag continues to edge of window whem in list item tag

RESOLVED INVALID

Status

()

Core
Layout
P4
normal
RESOLVED INVALID
16 years ago
15 years ago

People

(Reporter: Mathieu Fenniak, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9+)
Gecko/20020313
BuildID:    2002031303

The example link in the given URL can be clicked anywhere from the end of the
text all the way to the end of the window.

Reproducible: Always
Steps to Reproduce:
1. Open the given URL.
2. Move the mouse over the link 'Some Link Here', and then to the right of the link.


Actual Results:  As you move the mouse to the right of the link, the hand cursor
remains and you can still click to activate the link.

Expected Results:  Clicking on the space to the right of link should do nothing,
and a normal arrow cursor should exist.

Example HTML is:

<ul> <a href="http://poison.ous.ca/"><li>Link Here</a> More Text</ul>
Um... your <a> starts before the <li>, so all of the <li> is inside the anchor.
 The <li> extends all the way across, hence so does the anchor.  <li> is a
block, <a> is an inline, we end up having to promote <a> to a block because
inlines cannot contain blocks.

Fixing your markup would be a good first step...

Comment 2

16 years ago
Changing QA contact
QA Contact: petersen → amar

Updated

16 years ago
Priority: -- → P4
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Target Milestone: --- → Future
Marking invalid, since I feel that our rendering is correct given that markup.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.