TB does not recognize file system events for files in attachment list (MAC OS)

RESOLVED DUPLICATE of bug 722094

Status

Thunderbird
Message Compose Window
--
enhancement
RESOLVED DUPLICATE of bug 722094
a year ago
a year ago

People

(Reporter: Stefan, Unassigned)

Tracking

45 Branch
x86_64
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160916101415

Steps to reproduce:

I added a couple of attachments to a new mail.
Then I moved the file to another directory.


Actual results:

TB did not find the files afterwards.


Expected results:

TB should have reacted on the respective file system event, using FSEvents or KQueue.

see https://developer.apple.com/library/content/documentation/Darwin/Conceptual/FSEvents_ProgGuide/Introduction/Introduction.html

for an example in perl see here
http://stackoverflow.com/questions/11123007/check-which-files-have-changed-in-macfsevents-in-perl
(Reporter)

Updated

a year ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86_64

Comment 1

a year ago
It's a common problem on all platforms that if you move an attachment, it can't be found any more.

TB is a cross-platform application which runs on Windows, Mac and Linux and a single-platform solution won't get implemented.

WONTFIX, Magnus?
Severity: normal → enhancement
Flags: needinfo?(mkmelin+mozilla)
(Reporter)

Comment 2

a year ago
(In reply to Jorg K (GMT+2) from comment #1)
> It's a common problem on all platforms that if you move an attachment, it
> can't be found any more.

Mac users don't have common problems :-p

On Mac OS it's this is not a problem, ist is a common standard 
to follow up file changes (location & content). Even MS does it ...

Comment 3

a year ago
Rather than keeping track of the the file moving, the way forward should be to attach when you attach.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(mkmelin+mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 722094
You need to log in before you can comment on or make changes to this bug.