If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

thunderbird version 45.3.0 hangs with high cpu usage after startup, and unresponsive script. Works correctly after using safe mode once

RESOLVED WORKSFORME

Status

Thunderbird
General
--
major
RESOLVED WORKSFORME
a year ago
10 months ago

People

(Reporter: murphy.zhao, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36

Steps to reproduce:

did nothing, but start it, then it froze there after 1 miniute more or less


Actual results:

it just pop up one window message
  “Sent Items - Mozilla Thunderbird” is not responding.
  You may choose to wait a short while for it to continue or force the application to quit entirely"
then, it seems froze there for ever.

And the cpu usage was checked, almost 100% in one cpu.
Also strace the process with much much error like this:
  futex(0x7ff538200040, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)



Expected results:

expect it work normal
Which version of Thunderbird?
Which flavor of linux?
Does it also happen in safe mode?
 https://support.mozilla.org/en-US/kb/safe-mode
Severity: normal → critical
Component: Mail Window Front End → Untriaged
Flags: needinfo?(vseerror)
Keywords: hang
Flags: needinfo?(vseerror) → needinfo?(murphy.zhaoyh)
(Reporter)

Comment 2

11 months ago
Version:
thunderbird 45.2.0, and have update it to 45.3.0 and didn't help, still froze nearly instantly after startup.

System:
openSUSE Leap 42.1
(Reporter)

Comment 3

11 months ago
Hi,

It seems to work when started in safe mode and the add-on/extension has been checked, there is only one extension callled lightning.

It's a little weird that after that once safe-mode startup, I started the thunderbird as normal, without change anything, the issue just gone. Anyway, thanks for this suggestion. Please let me know if you still would like to debug more information.

Regards,
(In reply to murphy.zhao from comment #3)
> Hi,
> 
> It seems to work when started in safe mode and the add-on/extension has been
> checked, there is only one extension callled lightning.
> 
> It's a little weird that after that once safe-mode startup, I started the
> thunderbird as normal, without change anything, the issue just gone. 

Safe mode has been  known to do that.  One theory is it is a result of disabling the JIT compiler - https://en.wikipedia.org/wiki/SpiderMonkey

Apparently you are  not using the calendar functions??
Component: Untriaged → General
Summary: thunderbird version 45.3.0 hangs there with high cpu usage after startup → thunderbird version 45.3.0 hangs with high cpu usage after startup. Works correctly after using safe mode once
(Reporter)

Comment 5

11 months ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #4)
> 
> Safe mode has been  known to do that.  One theory is it is a result of
> disabling the JIT compiler - https://en.wikipedia.org/wiki/SpiderMonkey
> 
> Apparently you are  not using the calendar functions??

Didn't ever use it, but I see there is one "Calendar" folder in the left sidebar and some appointment emails there. Guess the function automatically enabled once the appointment email received.
(Reporter)

Comment 6

11 months ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #4)

> Safe mode has been  known to do that.  One theory is it is a result of
> disabling the JIT compiler - https://en.wikipedia.org/wiki/SpiderMonkey

Not much knowledge about the JIT compiler, but as reference to the strace output, it seemed like one polling issue with futex checking and returning immediately with error.
  "futex(0x7ff538200040, FUTEX_WAIT_PRIVATE, 2, NULL) = -1 EAGAIN (Resource temporarily unavailable)"

Regards,

Comment 7

11 months ago
Likely a duplicate of bug 1265242

Comment 8

11 months ago
Same problem here.
Since a few days Thunderbird will freeze when started.
I have only one addon installed (Lightning) and if I disable it via safe-mode, Thunderbird will start normally again.

I think the problem was introduced in one of the two last updates of Lightning.

Comment 9

11 months ago
Also for interactions with any add-ons, FB/FF/etc. must not block. 
The calling Mozilla (core?) component should add some timeout mechanism (for instance by spawning a thread) in order to protect the rest of the application from freezing.
murphy, so you are currently unable to reproduce, is that correct?

It's hard to tell from comment 0, but it sounds like "Unresponsive Script"
Severity: critical → major
Keywords: hang → perf
OS: Unspecified → Linux
Whiteboard: [closeme 2016-11-15 WFM]
(Reporter)

Comment 11

11 months ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #10)
> murphy, so you are currently unable to reproduce, is that correct?
> 
> It's hard to tell from comment 0, but it sounds like "Unresponsive Script"

Yeah, after your suggested safe-mode restart, the unresponsive issue didn't show up now. 
This issue happened both on my PC and laptop. I'll re-install my laptop this weekend, will check if this issue could be reproduced. Will keep you posted if it happens again.

Regards,
murphy, please share the results of your additional work. Thanks.
Summary: thunderbird version 45.3.0 hangs with high cpu usage after startup. Works correctly after using safe mode once → thunderbird version 45.3.0 hangs with high cpu usage after startup, and unresponsive script. Works correctly after using safe mode once
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → WORKSFORME
Whiteboard: [closeme 2016-11-15 WFM]
Flags: needinfo?(murphy.zhaoyh)
You need to log in before you can comment on or make changes to this bug.