Make it easier for pre-release users to download Firefox from /firefox/new/

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: agibson, Assigned: agibson)

Tracking

Production
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
Currently it's difficult for pre-release users to download the release version of Firefox from mozilla.org, and in particularly from /firefox/new/. We'd like to make that easier by showing the download button for pre-release users on /new, and also updating some of the messaging on the page to make things clearer.
(Assignee)

Updated

2 years ago
Depends on: 1305682
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1294723
(Assignee)

Updated

2 years ago
Assignee: nobody → agibson
Status: NEW → ASSIGNED
(Assignee)

Comment 2

2 years ago
One of the asks for this bug has been to call out the specific channel a Firefox user is on when visiting /new, via some form of in-page messaging. We did some research here using the two options we have available to give us this data, but both have caveats that we think will not give a consistently high level of user experience:

1.) UITour API. Using this API gives false positives when Firefox Beta updates to release candidate (see Bug 1302468).
2.) Product details. This gives us the current major version numbers for each channel, however users don't always update their browsers quickly. For example, if a Firefox 50 Beta user visits /new after Release has updated to version 50, but before their own browser has been updated, then bedrock will assume they are on Release channel and not Beta.

Because of these gray areas of overlap for Beta users we recommend the doing following:

1.) We always show the green download button to Firefox users (irrespective of the users Channel).
2.) If the user is on a version > than current release version, display some channel neutral messaging e.g. "It looks like you're on a pre-release version of Firefox".
3.) If a user is on a version == to the current release version, display the download green button (instead of the blue "Refresh Firefox" button), together with a smaller link to a SUMO article that gives instructions on how to refresh Firefox.
(Assignee)

Comment 3

2 years ago
Created attachment 8801705 [details]
firefox-new-states.png

Attached screenshots of proposed states.

Proposed copy for up to date users
----------------------------------

"Congrats! You're using the latest version of Firefox."

Headline: "Browse freely"

Button: "Free download"

Links:

"Reset your add-ons and settings" [https://support.mozilla.org/kb/refresh-firefox-reset-add-ons-and-settings]

"Need more help?" [https://support.mozilla.org/products/firefox]

Proposed copy for pre-release users
-----------------------------------

"You’re using a pre-release version of Firefox."

Headline: "Browse freely"

Button: "Free download"

Links: "Update Firefox to the latest version" [https://support.mozilla.org/products/firefox/install-and-update-firefox]
(Assignee)

Comment 4

2 years ago
Jen, any thoughts on the proposed copy / screenshots above?

I've tried to keep things short while addressing both pre-release users and up-to-date users.

I'm not quite clear on where we're at with wanting to do an A/B test, or what we're trying to find out there specifically. My gut says if we want to play around with keeping the "Refresh Firefox" button showing up instead of the green download button, then we should probably split this off into a separate piece of work, and make that block this bug. Let me know what you would like to do.
Flags: needinfo?(jbertsch)
(Assignee)

Comment 5

2 years ago
This is also up on a demo:

https://bedrock-demo-agibson.us-west.moz.works/en-US/firefox/new/?v=b

Note: the URL is ?v=b for now, but I'm not 100% sure if we're A/B testing.
Alex - I spoke to Jen and the outcome here is that she would like us to go forward with and A/B/C test for Up-to-date users (the pre-release page you have created is perfect, needs no change, won't be tested).

For the up-to-date users test:

A = the current page as control (I will ask Peter about the 'double control' here)
B = slight variation, as detailed below
C = Download button, Refresh Button, copy/link to products/ff

========================

Version B

"Congrats! You're using the latest version of Firefox."

Headline: "Browse freely"

Links (in this order):

"Reset your add-ons and settings" [https://support.mozilla.org/kb/refresh-firefox-reset-add-ons-and-settings] (Not the refresh button)

"Need more help?" [https://support.mozilla.org/products/firefox]

Button: "Free download"

========================

Version C:  

The Download Button |  The Refresh Button

"Need more help?" [https://support.mozilla.org/products/firefox]

========================

Let me know of any questions, please
Flags: needinfo?(jbertsch) → needinfo?(agibson)
(Assignee)

Comment 7

2 years ago
Like I tried to explain above, I think we might be trying to bundle up too much logic here to test all in one go. I need to try and think this one through.
Flags: needinfo?(agibson)
(In reply to Alex Gibson [:agibson] from comment #7)
> Like I tried to explain above, I think we might be trying to bundle up too
> much logic here to test all in one go. I need to try and think this one
> through.

Hey Alex-

Sorry - I'm trying to do too many things at once.

I do think we need to find a way to balance actually helping people who aren't having a good experience with Firefox - and downloading again doesn't help that vs people who have legitimate reasons to download.  

I'm fine if we need to run to separate A/B tests.  

My goal is to see if we can improve engagement on the page as a proxy for helping existing user complete their goal in coming to the page - clearly these Firefox users are coming to the page to do something, we just don't have a great understanding of exactly what it is.  I've talked to the SUMO team and there's not a lot beyond Refresh that we offer as a "one stop fits all" fix (other than instructions on how to update manually).  And a lot of problems are related to the web pages people are visiting, not the product itself.
(Assignee)

Comment 9

2 years ago
Ok I'm going to split this out into two separate bugs. Because we don't need to include the pre-release page state as part of the A/B/C test proposed in Comment 6, I'm just going to tackle that here in this bug. It can them be localized and form part of the regular template. I'll file a separate bug for testing the Refresh Button, which does now feel a bit more like a separate user story to the one we started out with here. Thanks :)
(Assignee)

Comment 10

2 years ago
Created attachment 8802064 [details] [review]
GitHub pull request
(Assignee)

Comment 11

2 years ago
Jen, before we expose strings for the pre-release page state, I'd like to double-check that we're OK to move forward with the following two new strings:

"You’re using a pre-release version of Firefox."
"Update Firefox to the latest version" (SUMO link)
Flags: needinfo?(jbertsch)
(Assignee)

Comment 12

2 years ago
I filed Bug 1310978 to discuss further A/B testing for up-to-date Firefox users.
(Assignee)

Updated

2 years ago
Blocks: 1310978
(Assignee)

Comment 13

2 years ago
Hi Peter,

Up until now we've been flagging both up-to-date users on release channel and pre-release users in GA with a 'set-state' event value of "Desktop, Firefox up-to-date". With the change in this bug we're now displaying a download button for pre-release users. 

Would you like to keep the page reporting states as they are currently, or alternatively we could start sending "Desktop, Firefox pre-release" as a new state?

Happy to discuss this further if needed, thanks.
Flags: needinfo?(peter.german.bugs)
(Assignee)

Comment 14

2 years ago
The branch for this bug is now updated on demo: https://bedrock-demo-agibson.us-west.moz.works/en-US/firefox/new/
(In reply to Alex Gibson [:agibson] from comment #11)
> Jen, before we expose strings for the pre-release page state, I'd like to
> double-check that we're OK to move forward with the following two new
> strings:
> 
> "You’re using a pre-release version of Firefox."
> "Update Firefox to the latest version" (SUMO link)

Hi Alex-

Again, sorry about the confusion.

Please do expose "You’re using a pre-release version of Firefox." for L10N.

Let's remove "Update Firefox to the latest version" from the pre-release version of the page.

Thanks,
Jen
Flags: needinfo?(jbertsch)
(In reply to Alex Gibson [:agibson] from comment #14)
> The branch for this bug is now updated on demo:
> https://bedrock-demo-agibson.us-west.moz.works/en-US/firefox/new/

Have you tested on Dev Edition or just Beta?  When I tried the link in Dev Edition, I got the "Congrats you are up to date" message instead of the "You're using pre-release."  But maybe that is just my profile being weird?
(Assignee)

Comment 17

2 years ago
(In reply to Jennifer Bertsch [:jbertsch] from comment #15)
> (In reply to Alex Gibson [:agibson] from comment #11)
> > Jen, before we expose strings for the pre-release page state, I'd like to
> > double-check that we're OK to move forward with the following two new
> > strings:
> > 
> > "You’re using a pre-release version of Firefox."
> > "Update Firefox to the latest version" (SUMO link)
> 
> Hi Alex-
> 
> Again, sorry about the confusion.
> 
> Please do expose "You’re using a pre-release version of Firefox." for L10N.
> 
> Let's remove "Update Firefox to the latest version" from the pre-release
> version of the page.
> 
> Thanks,
> Jen

Will update, thanks
(Assignee)

Comment 18

2 years ago
(In reply to Jennifer Bertsch [:jbertsch] from comment #16)
> (In reply to Alex Gibson [:agibson] from comment #14)
> > The branch for this bug is now updated on demo:
> > https://bedrock-demo-agibson.us-west.moz.works/en-US/firefox/new/
> 
> Have you tested on Dev Edition or just Beta?  When I tried the link in Dev
> Edition, I got the "Congrats you are up to date" message instead of the
> "You're using pre-release."  But maybe that is just my profile being weird?

As discussed on IRC, your browser was in need of updating.

Comment 19

2 years ago
Hi Alex,

That code can be deprecated. The state variable is not being used by any tags in GTM and the set-state event does not trigger any tags either.

Thanks,

PG
Flags: needinfo?(peter.german.bugs)
(Assignee)

Comment 20

2 years ago
(In reply to Peter German from comment #19)
> Hi Alex,
> 
> That code can be deprecated. The state variable is not being used by any
> tags in GTM and the set-state event does not trigger any tags either.
> 
> Thanks,
> 
> PG

Removing legacy code is even better, thanks for digging in :)

Comment 21

2 years ago
Commits pushed to master at https://github.com/mozilla/bedrock

https://github.com/mozilla/bedrock/commit/2eca27d672516ebe5524e7d415f7efbf11f202a9
[fix bug 1308973] Make it easier for pre-release users to download Firefox from /firefox/new/

https://github.com/mozilla/bedrock/commit/59e9bc7c57cab94747e77abb7af17616dab2725c
Merge pull request #4419 from alexgibson/bug-1308973-pre-release-users

[fix bug 1308973] Make it easier for pre-release users to download Firefox from /firefox/new/

Updated

2 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.