If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

After logging in, user is redirected to Pontoon homepage instead staying on the same page

RESOLVED FIXED

Status

Webtools
Pontoon
P2
normal
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: Tomáš Zelina (Mozilla.cz), Assigned: jotes)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
Steps to reproduce:

1) Log out (if you were logged in)
2) Go to any page except of homepage (for example https://pontoon.mozilla.org/cs/amo/LC_MESSAGES/django.po/)
3) Click 'Sign in' link

Expected behavior:
After login user will still be on the same page as before

Actual results:
User is redirected to https://pontoon.mozilla.org/



It is especially annoying when you find specific string you want to fix, but after login you have to search it again.



(I've tried to search if this wasn't reported before, but haven't found anything, so sorry if this is a duplicate)
Confirmed. That's a regression, introduced by bug 1218794.
Priority: -- → P3
(Assignee)

Updated

a year ago
Assignee: nobody → jot
(Assignee)

Comment 2

a year ago
:mathjazz

I fixed this issue locally for Firefox Accounts.
However, I discovered that django-allauth doesn't handle a 'next' parameter in case of persona provider: https://github.com/pennersr/django-allauth/blob/master/allauth/socialaccount/providers/persona/templates/persona/auth.html#L9

My question is: How much urgent is this issue for Persona? Because in the face of the incomining decomission in the next 20 days, we'll have to patch django-allauth implementation.
Let's ignore Persona in this case.

Updated

11 months ago
Priority: P3 → P2

Comment 4

11 months ago
Commit pushed to master at https://github.com/mozilla/pontoon

https://github.com/mozilla/pontoon/commit/be16ccd9ae16aa63e379ca22004c171277e9f67c
Fix bug 1308983 - fixed redirect after sign in. (#478)

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → FIXED

Comment 5

11 months ago
Commit pushed to master at https://github.com/mozilla/pontoon

https://github.com/mozilla/pontoon/commit/0841b68021faad1a00cc5613f8c3d9ad79863f5a
Fix admin form submission regression from be16ccd (#482)

A patch to fix bug 1308983 (commit be16ccd) introduced a form element,
which prevented the Admin form to be submitted due to too general
form selector in JS.
You need to log in before you can comment on or make changes to this bug.