If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

loading Mozilla before Quicklaunch finishes "breaks" URL window

VERIFIED DUPLICATE of bug 147223

Status

Core Graveyard
QuickLaunch (AKA turbo mode)
VERIFIED DUPLICATE of bug 147223
16 years ago
5 years ago

People

(Reporter: Tony Tovar, Assigned: Bill Law)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
This is with release 0.9.9 on WinNT.
I installed this release two days ago and have had more problems with it than
with any release in the past year!  This morning, I discovered that I am unable
to enter a URL by hand; Mozilla flashes the "Loading" message for a split second
and then reports Done but without loading anything.  I'll still have the
previous web-page, or (if I open a new Tab) a blank page.

I don't remember if this was a problem yesterday or not.  The only thing that
*might* be different today was that I remember double-clicking the desktop icon
before Windows (and the Mozilla Quicklaunch) had finished loading.  Could that
have messed-up the program?  After submitting this, I'll try unloading/reloading
Mozilla...
(Reporter)

Comment 1

16 years ago
Another oddity:
The URL shown in the text window is still the one I tried unsuccessfully to
type.  It's not changing to reflect the current page?!  

My Bookmarks still work fine, as do links on the pages (which is how I was able
to get to Bugzilla and submit this).
(Reporter)

Comment 2

16 years ago
I isolated the problem.  Clicking on the Mozilla icon while Quicklaunch is still
loading results in a corrupt browser window.  The URL window ignores both
manually-entered URLs and the currently viewed URL.  Closing and re-opening the
browser window fixes the problem.

It looks like the Mozilla executable (only on Windows?) needs to check the
status of Quicklaunch so that it correctly initializes.
Summary: manually entered URLs are ignored → loading Mozilla before Quicklaunch finishes "breaks" URL window

Comment 3

16 years ago
bug 134185 may be a dup.

Comment 4

16 years ago
According to law@netscape.com in irc, this is a real problem, and there may be
an older nsbeta1- bug related to this that describes a potential fix.  I don't
have time to find it now, but I know it's not an open bug in the Quicklaunch
component, in case anybody wants to look.  

Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
*** Bug 134185 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
moving to quicklaunch
Component: Browser-General → QuickLaunch (AKA turbo mode)

Comment 7

16 years ago
reproduced here with 9.9
changing assignee and QA

Bill, please reassign as necessary
Assignee: asa → law
QA Contact: doronr → gbush

Comment 8

16 years ago
*** Bug 132662 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

16 years ago
With build 2002-04-26-06 (1.0 branch) on WinNT, I'm still seeing strange
behavior when I repeatedly double-click the Mozilla icon while Quicklaunch is
still loading. I end up with some broken windows (nothing but a title-bar) as
well as one "ok" window; I forgot to check if the "ok" window accepted manual
URLs, though.  

Also, I don't see this bug listed as a dependency for the tracking bug 75599 so
I'm (trying) to add it as a blocker.
Blocks: 75599

Comment 10

15 years ago
Bill, 

Shouldn't the fix for bug 147223 solve this problem?

Comment 11

15 years ago
You are correct and, in fact, this is a dup of that bug.

*** This bug has been marked as a duplicate of 147223 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 12

15 years ago
verified
Status: RESOLVED → VERIFIED
No longer blocks: 75599
Component: QuickLaunch (AKA turbo mode) → QuickLaunch (AKA turbo mode)
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.