Preference parsing warnings report incorrect line numbers

RESOLVED DUPLICATE of bug 1423840

Status

()

P3
enhancement
RESOLVED DUPLICATE of bug 1423840
3 years ago
a year ago

People

(Reporter: mao, Assigned: mao)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox52 wontfix)

Details

(URL)

(Assignee)

Description

3 years ago
Bug 278878 introduced some warnings sent to the browser console when unexpected things happen while parsing preference files.
Unfortunately those messages are less useful than they could, because line numbers are not reported correctly.
Here we want to improve this information, providing the correct line number at least, if not the column as well.

Originally reported here: https://forums.informaction.com/viewtopic.php?f=14&t=21752

Comment 1

3 years ago
(In reply to Giorgio Maone [:mao] from comment #0)
> Originally reported here:
Er, you meant this one right? https://forums.informaction.com/viewtopic.php?f=7&t=22186
Giorgio, fixing this would be great; the parser code is convoluted enough that I only got close to the right line number with bug 278878, but it's often incorrect.
Too late for firefox 52, mass-wontfix.
status-firefox52: affected → wontfix

Updated

2 years ago
Severity: normal → enhancement
Priority: -- → P3
Bug 1423840 rewrote the prefs parser. It now does a much better job with line numbers in error messages.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1423840
You need to log in before you can comment on or make changes to this bug.