Intermittent Linux 'mach build' did not run successfully. Please check log for errors. because of g++: internal compiler error: Segmentation fault (program cc1plus)

RESOLVED DUPLICATE of bug 1308685

Status

()

Core
Build Config
RESOLVED DUPLICATE of bug 1308685
a year ago
a year ago

People

(Reporter: aryx, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

https://treeherder.mozilla.org/logviewer.html#?job_id=4842172&repo=autoland

At least since last week, there are more build failures due to internal compiler errors like this:

[task 2016-10-11T09:08:45.042570Z] 09:08:45     INFO -  gmake[5]: Entering directory `/home/worker/workspace/build/src/obj-firefox/dom/media/platforms/ffmpeg'
[task 2016-10-11T09:08:45.042751Z] 09:08:45     INFO -  mkdir -p '.deps/'
[task 2016-10-11T09:08:45.103893Z] 09:08:45     INFO -  /usr/bin/ccache /home/worker/workspace/build/src/gcc/bin/g++ -m32 -march=pentiumpro -std=gnu++11 -o Unified_cpp_platforms_ffmpeg0.o -c -I/home/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/home/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /home/worker/workspace/build/src/config/gcc_hidden.h -DDEBUG=1 -DTRACING=1 -DSTATIC_EXPORTABLE_JS_API -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/home/worker/workspace/build/src/dom/media/platforms/ffmpeg -I/home/worker/workspace/build/src/obj-firefox/dom/media/platforms/ffmpeg  -I/home/worker/workspace/build/src/obj-firefox/dist/include  -I/home/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/home/worker/workspace/build/src/obj-firefox/dist/include/nss       -fPIC  -DMOZILLA_CLIENT -include /home/worker/workspace/build/src/obj-firefox/mozilla-config.h -MD -MP -MF .deps/Unified_cpp_platforms_ffmpeg0.o.pp  -Wall -Wc++11-compat -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wsign-compare -Wtype-limits -Wunreachable-code -Wwrite-strings -Wno-invalid-offsetof -Wno-error=maybe-uninitialized -Wno-error=deprecated-declarations -Wno-error=array-bounds -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -D_GLIBCXX_USE_CXX11_ABI=0 -pipe  -g -freorder-blocks -Os -fno-omit-frame-pointer  -Werror   /home/worker/workspace/build/src/obj-firefox/dom/media/platforms/ffmpeg/Unified_cpp_platforms_ffmpeg0.cpp
[task 2016-10-11T09:08:45.150101Z] 09:08:45     INFO -  In file included from /home/worker/workspace/build/src/obj-firefox/image/decoders/Unified_cpp_image_decoders0.cpp:56:0:
[task 2016-10-11T09:08:45.150328Z] 09:08:45     INFO -  /home/worker/workspace/build/src/image/decoders/nsPNGDecoder.cpp:1105:1: internal compiler error: Segmentation fault
[task 2016-10-11T09:08:45.150381Z] 09:08:45     INFO -   } // namespace mozilla
[task 2016-10-11T09:08:45.150507Z] 09:08:45     INFO -   ^
[task 2016-10-11T09:08:45.150557Z] 09:08:45     INFO -  0x8c034f crash_signal
[task 2016-10-11T09:08:45.150602Z] 09:08:45     INFO -  	../../gcc-4.8.5/gcc/toplev.c:332
[task 2016-10-11T09:08:45.151031Z] 09:08:45     INFO -  g++: internal compiler error: Segmentation fault (program cc1plus)
[task 2016-10-11T09:08:45.151207Z] 09:08:45     INFO -  0x4097a0 execute
[task 2016-10-11T09:08:45.151263Z] 09:08:45     INFO -  	../../gcc-4.8.5/gcc/gcc.c:2823
[task 2016-10-11T09:08:45.151499Z] 09:08:45     INFO -  Please submit a full bug report,
[task 2016-10-11T09:08:45.151641Z] 09:08:45     INFO -  with preprocessed source if appropriate.
[task 2016-10-11T09:08:45.151707Z] 09:08:45     INFO -  Please include the complete backtrace with any bug report.
[task 2016-10-11T09:08:45.151943Z] 09:08:45     INFO -  See <http://gcc.gnu.org/bugs.html> for instructions.
[task 2016-10-11T09:08:45.152089Z] 09:08:45     INFO -  gmake[5]: *** [Unified_cpp_image_decoders0.o] Error 4
[task 2016-10-11T09:08:45.152153Z] 09:08:45     INFO -  gmake[5]: *** Deleting file `Unified_cpp_image_decoders0.o'
[task 2016-10-11T09:08:45.152461Z] 09:08:45     INFO -  gmake[5]: Leaving directory `/home/worker/workspace/build/src/obj-firefox/image/decoders'
[task 2016-10-11T09:08:45.152529Z] 09:08:45     INFO -  gmake[4]: *** [image/decoders/target] Error 2
[task 2016-10-11T09:08:45.152757Z] 09:08:45     INFO -  gmake[4]: *** Waiting for unfinished jobs....
Since that line appears in every single build failure's log, you really can't have an intermittent-failure bug with that in the summary.
Status: NEW → RESOLVED
Last Resolved: a year ago
Keywords: intermittent-failure
Resolution: --- → DUPLICATE
Duplicate of bug: 1308685
You need to log in before you can comment on or make changes to this bug.