Closed Bug 1309306 Opened 5 years ago Closed 4 years ago

Async Rendering Plugin 1.0 AddOn-Firefox 49.0.1-Adobe Flash 23.0 - Private Window

Categories

(Core :: Plug-ins, defect)

49 Branch
x86_64
Windows 8.1
defect
Not set
normal

Tracking

()

RESOLVED INCOMPLETE

People

(Reporter: mfunches, Unassigned)

References

Details

(Whiteboard: hold)

Attachments

(2 files)

Attached image async_blackscreen.JPG
Ensure Fx 49.0.1, Adobe Flash 23.0 and Async Rendering Plugin 1.0
Open http://www.cnn.com/2016/10/10/us/weather-matthew/index.html
Observe video plays
Open a New Private Window
Open http://www.cnn.com/2016/10/10/us/weather-matthew/index.html in the private window
Observe: Black screen - video will not play.
Tested e10s enabled and disabled results were the same, the video does not play, screenshot attached
Flags: needinfo?(blassey.bugs)
This works for me on Win10 64bit on Nightly. Is you Firefox a 32 or 64bit build?
Flags: needinfo?(blassey.bugs)
On Windows 7 virtual machine 
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0

http://www.cnn.com/2016/10/10/us/weather-matthew/index.html
In Private Window, I do observe black screen for some videos and for others I get the video content but audio is screechy. Not e10s specific.
I am seeing this on Windows 8.1 with Firefox 32-bit build. Also Kanchan is seeing related behavior on Windows 7 with Firefox 32-bit build. In Kanchans' case sometimes the video does not play there is only the black screen. Other times the video plays but the sound is inaudible or screechy.
BTW: it should also be noted that both of us are testing on VMs.
David, any ideas here? Is there *any* reason private browsing would cause Flash to not be able to render video?
Flags: needinfo?(dvander)
Private browsing is exposed through NPAPI but I can't imagine any reason on our end that'd affect rendering.
Flags: needinfo?(dvander)
Tracking protection maybe?
QA Update: testing private windows today was functioning w/o error with e10s enabled. Also when testing with both of the pref changes flipped.
Blocks: 1229961
Produced a Adobe Flash Plugin Crash in Private Window
Version 	49.0.2
Build ID 	20161019084923
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:49.0) Gecko/20100101 Firefox/49.0
MAC OS Sierra 10.12.1
2.5 GHz Intel Core i5
4 GB 1600 MHz DDR3
Intel HD Graphics 4000 1536 MB
Shockwave Flash 23.0.0.185
Crashes on OSX are a different issue, aren't they? I thought this feature only affected Windows.
Similar to Bug#1276426 - while Mac should not be effected I am again seeing that there appears to be interference
49.0.2 async false, no problem displaying the site in a private window
49.0.2 async true, I get an Adobe Plugin crash (not consistent)
Flags: needinfo?(twalker)
Whiteboard: hold
I was best able to observe issues with this site/video in a Win7 VM.  In all cases, I saw a black video screen (often with some sort of site generated red square "spinner") to begin with, but after several seconds the video would begin playing. There was no appreciable difference between normal or private browsing modes. What I observed was varying performance quality as follows:

With latest Nightly 52.0a1, 20161026030210 performance was fine except for the wait to get out of the black screen.

With Firefox 49.0.2, 20161019084923: dom.ipc.plugins.asyncdrawing.enabled = true, the video performance is choppy and slow

With Firefox 49.0.2, 20161019084923: dom.ipc.plugins.asyncdrawing.enabled = false, the video performance is better, but doesn't feel as smooth as Nightly.

Somewhere in testing for this bug I picked up a crash report. I wasn't aware the browser had crashed. But showed up as unsubmitted on restart. https://crash-stats.mozilla.com/report/index/b8bf34f3-6b77-4d4b-a2b8-860ab2161026
Flags: needinfo?(twalker)
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.