Wrong Lightning version in SeaMonkey 2.46 build 6 Release Candidate

RESOLVED FIXED in 5.2

Status

Calendar
Build Config
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

Trunk
Unspecified
Windows

Details

Attachments

(2 attachments)

(Assignee)

Description

2 years ago
Created attachment 8799979 [details]
Capture.PNG

Release candidate seems to work fine but shows a wrong .4.46 version for Lightning.

Downloaded from here:
https://archive.mozilla.org/pub/seamonkey/candidates/2.46-candidates/build6/unsigned/win32/en-US/
(Assignee)

Updated

2 years ago
OS: Unspecified → Windows
Summary: Wrong Lightning version in build 6 2.46 release Ccndidate → Wrong Lightning version in 2.46 build 6 Release Candidate
(Assignee)

Comment 1

2 years ago
Possibly a duplicate or followup of bug 1293943.
(Assignee)

Updated

2 years ago
Blocks: 1294433
(Assignee)

Comment 2

2 years ago
Fallen,

wrt your comment yesterday on irc. Can the use of MOZ_PKG_VERSION be dropped from the makefile code which generates the Lightning version? I think the Thunderbird version is always accessible/usable or not?

FRG
Flags: needinfo?(philipp)
It was probably added for a reason. I assume that reason is that for release or beta builds, MOZ_PKG_VERSION may be set to something different than in version.txt
Flags: needinfo?(philipp)
(Assignee)

Comment 4

2 years ago
Hmm, what do you suggest? 

Maybe testing for SeaMonkey, setting a different variable with the content of MOZ_PKG_VERSION when not SeaMonkey and use this for version generation?

Or changing makeversion.py to detect the SeaMonkey version?
Flags: needinfo?(philipp)
You could try an if/else block that uses what we are doing now for Thunderbird and ignoring MOZ_PKG_VERSION otherwise. In the worst case this may mean wrong version numbers in the Seamonkey builds in situations where building Thunderbird on the same tree would have a difference between MOZ_PKG_VERSION and version.txt.

If you are making changes to both lightning and gdata Makefiles, you might also want to refactor all the version variables into calendar/lightning/versions.mk and include from both.
Flags: needinfo?(philipp)
(Assignee)

Comment 6

2 years ago
Created attachment 8805837 [details] [diff] [review]
1309372-lightning-version.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: Seamonkey release builds include a lightning with wrong version information.
Testing completed (on m-c, etc.): c-r
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: none
Assignee: nobody → frgrahl
Status: NEW → ASSIGNED
Attachment #8805837 - Flags: review?(philipp)
Attachment #8805837 - Flags: approval-comm-release?
Attachment #8805837 - Flags: approval-comm-beta?
Attachment #8805837 - Flags: approval-comm-aurora?
(Assignee)

Updated

2 years ago
Component: Build Config → Build Config
Flags: approval-comm-release?
Flags: approval-comm-beta?
Flags: approval-comm-aurora?
Product: SeaMonkey → Calendar
Version: SeaMonkey 2.46 Branch → Trunk
(Assignee)

Updated

2 years ago
Summary: Wrong Lightning version in 2.46 build 6 Release Candidate → Wrong Lightning version in SeaMonkey 2.46 build 6 Release Candidate
(Assignee)

Updated

2 years ago
Attachment #8805837 - Flags: approval-calendar-beta?(philipp)
Attachment #8805837 - Flags: approval-calendar-aurora?(philipp)
Can you do a Thunderbird try run for this?
(Assignee)

Comment 8

2 years ago
I likely didn't use the right try syntax to build all platforms but the patch looks ok to me. The bustage in the x64 test is from a different bug.

Checking the logs I see -DLIGHTNING_VERSION=5.4a1 which is the expected result.

https://treeherder.mozilla.org/#/jobs?repo=try-comm-central&revision=6277ffac4e6503d78a84a5ba0924079b694973d7
Attachment #8805837 - Flags: review?(philipp)
Attachment #8805837 - Flags: review+
Attachment #8805837 - Flags: approval-calendar-beta?(philipp)
Attachment #8805837 - Flags: approval-calendar-beta+
Attachment #8805837 - Flags: approval-calendar-aurora?(philipp)
Attachment #8805837 - Flags: approval-calendar-aurora+
(Assignee)

Comment 9

2 years ago
https://hg.mozilla.org/comm-central/rev/807b9f10a95cba9260196561fb9c3fc719ef54c9

I will wait till tomorrow and push them to the branches then.
Keywords: leave-open
Target Milestone: --- → 5.5
Target Milestone: 5.5 → 5.2
You need to log in before you can comment on or make changes to this bug.