[jsplugins][Meta] Implement the back-end part of printing pdf file functionality

RESOLVED DUPLICATE of bug 1347444

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1347444
2 years ago
11 months ago

People

(Reporter: louis, Assigned: louis)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
This bug is to implement the back-end part of printing pdf file functionality.
(Assignee)

Updated

2 years ago
Assignee: nobody → lochang
No longer depends on: 1286498, 1286499
(Assignee)

Updated

2 years ago
Blocks: 1309444
(Assignee)

Updated

2 years ago
No longer blocks: 1309444
(Assignee)

Updated

2 years ago
Depends on: 1311589
(Assignee)

Comment 1

a year ago
Set this bug as Meta bug of implementing pdf printing functionality in runtime.

And the rough flow of the printing is as below:
User press the print button
-> We first call |PPP_Messaging::HandleMessage| with type "print" to PDFium.
-> PDFium then call |PPB_PDF::Print|.
-> In |PPB_PDF::Print| we should somehow get print settings from user. Next, we successive call |PPP_Printing::Begin|, |PPP_Prining::PrintPages| and |PPP_Printing::End| to get the PDF binary from PDFium. -> At last, PDFium will call |PPP_PDF::UserMetricsRecordAction| with action "PDF.PrintPage".
-> Then we could somehow send the binary to gecko and print it.
Summary: [jspluigins] Implement the back-end part of printing pdf file functionality → [jspluigins][Meta] Implement the back-end part of printing pdf file functionality
(Assignee)

Updated

a year ago
Depends on: 1311586, 1315198
(Assignee)

Updated

a year ago
Depends on: 1321236
(Assignee)

Updated

a year ago
Depends on: 1328495

Updated

a year ago
Blocks: 1269760

Updated

a year ago
Duplicate of this bug: 1286498
(Assignee)

Updated

a year ago
No longer blocks: 1269760
Summary: [jspluigins][Meta] Implement the back-end part of printing pdf file functionality → [jsplugins][Meta] Implement the back-end part of printing pdf file functionality

Updated

a year ago
Blocks: 1269760
No longer blocks: 1264551

Updated

a year ago
Group: mozilla-employee-confidential
(Assignee)

Updated

a year ago
No longer depends on: 1328495
(Assignee)

Updated

a year ago
Depends on: 1346682

Updated

11 months ago
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1347444
You need to log in before you can comment on or make changes to this bug.