Closed Bug 1309487 Opened 4 years ago Closed 4 years ago

include longdescs.count in result for /rest/bug

Categories

(bugzilla.mozilla.org :: API, defect)

Production
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: emceeaich, Assigned: dkl)

References

Details

Attachments

(1 file, 1 obsolete file)

You can search on longdescs.count, but don't get the number of comments back in the bug.
Attached patch 1309487_1.patch (obsolete) — Splinter Review
Assignee: nobody → dkl
Status: NEW → ASSIGNED
Attachment #8800299 - Flags: review?(dylan)
Comment on attachment 8800299 [details] [diff] [review]
1309487_1.patch

r=dylan but we might want to support comments_count primarily and just fall back on longdescs.count (but not document that at all)
Attachment #8800299 - Flags: review?(dylan) → review+
Attached patch 1309487_2.patchSplinter Review
> r=dylan but we might want to support comments_count primarily and just fall 
> back on longdescs.count (but not document that at all)

Changed to comment_count and added to FIELD_MAP. Please do a quick sanity check.

dkl
Attachment #8800299 - Attachment is obsolete: true
Attachment #8800887 - Flags: review?(dylan)
Comment on attachment 8800887 [details] [diff] [review]
1309487_2.patch

Review of attachment 8800887 [details] [diff] [review]:
-----------------------------------------------------------------

r=dylan
Attachment #8800887 - Flags: review?(dylan) → review+
To https://github.com/mozilla-bteam/bmo.git
   4337c8d..cc31416  master -> master
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1440227
Blocks: 1440227
You need to log in before you can comment on or make changes to this bug.