Terminate button has no immediate effect

RESOLVED DUPLICATE of bug 1309597

Status

P2
normal
RESOLVED DUPLICATE of bug 1309597
2 years ago
2 years ago

People

(Reporter: rvitillo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User Story

It appears that the terminate button in the cluster detail page has not always an immediate effect, even though on the EMR console the cluster is labelled terminating.
Comment hidden (empty)

Updated

2 years ago
Points: --- → 1
Priority: -- → P2
Terminating the cluster fetches the cluster info right away from AWS which itself may not have updated the state via the API. The eventual update of the cluster state is because we additionally update the cluster info every minute.

To lower the amount of time the new info shows up I think we should schedule fetching the cluster info via our task system when we terminate it via ATMO as well.

Alternatively we could even block the terminate form submission until the state has changed that we fetch from AWS, e.g. with a timeout of 2 seconds or something small.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1309597
You need to log in before you can comment on or make changes to this bug.