unable to run mach on my windows10 machine today, I get: Could not run mach: No mach source directory found

RESOLVED WORKSFORME

Status

Firefox Build System
General
RESOLVED WORKSFORME
2 years ago
5 months ago

People

(Reporter: jmaher, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

somehow my windows environment got messed up, and I am 100% in the dark on this development environment.

Using windows build I used to be able to start the shell and then do my normal hg and mach commands.  This worked great until this morning when the shell wouldn't start (bug 1309541).   I reverted a windows OS update, now I can get to my cygwin/bash prompt :)

once there, I found out that hg was limited (my strip command failed as there were no extensions defined).  I fixed this by editing my hgrc file.  Outside of that I wanted to run mach, so I tried:
mach clobber
./mach clobber

both end up with:
Could not run mach: No mach source directory found.

I am not sure how to self correct here- it is so expensive to start over again in regards to network bandwidth and time.

Comment 1

2 years ago
The "No mach source directory found" error is from `mach` itself. When you run `mach`, it traverses the current working directory, looking for mozinfo.json (objdir) or config.status (topsrcdir). If it can't find those or a "build/mach_bootstrap.py" file at the resolved topsrcdir, you get this error.

Assuming your checkout is sane and you are running `./mach`, you should *never* get this failure. Are you sure you were running `./mach` and not `mach` (which may resolve to a random executable in PATH)?

Assuming you run `./mach` my best guess is your checkout is incomplete/corrupt. What does `hg status` say? You can "reset" your checkout by doing something like:

  $ hg up -C null
  $ hg up central
Flags: needinfo?(jmaher)
hg status has 492 files in the ! state, all in the build/ directory.

both |mach| and |./mach| fail in the same way.

and the:
hg up null
hg up central

fixed my issues.  feel free to resolved as worksforme if there is nothing to do to fix this.
Flags: needinfo?(jmaher)

Comment 3

2 years ago
Yeah, somehow your working directory got corrupt :/
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME

Updated

5 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.