Document CustomElementRegistry.define()

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: brokenalarms, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

2 years ago
:: Developer Documentation Request

      Request Type: Correction
     Gecko Version: unspecified
 Technical Contact: 

:: Details

link here: https://developer.mozilla.org/en-US/docs/Web/Web_Components/Custom_Elements

contains a link to: 

https://developer.mozilla.org/en-US/docs/Web/API/customElements.define

which gives 404.

Given this seems to be currently the only place online that describes the customElements.define API, I can't currently see how to use this API at all.

Comment 1

2 years ago
Thanks for reporting. 
New page must be created for customElements.define() method
Status: UNCONFIRMED → NEW
Component: API: DOM → API: HTML
Ever confirmed: true
Flags: needinfo?(jypenator)
The correct page missing here:
https://developer.mozilla.org/en-US/docs/Web/API/CustomElementRegistry/define

But the whole area is not documented.
Flags: needinfo?(jypenator)
Summary: 404 for link to customELements.define → Document CustomElementRegistry.define()
The page exists now
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.