Don't double-call EnsureProcessTerminated for the GPU process

RESOLVED FIXED in Firefox 52

Status

()

Core
Graphics
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

unspecified
mozilla52
Points:
---

Firefox Tracking Flags

(firefox52 fixed)

Details

Attachments

(1 attachment)

This is causing crashes when I run opt tests locally, not sure if it's behind some TreeHerder crashes yet.
Created attachment 8800989 [details] [diff] [review]
fix

GeckoChildProcessHost already calls EnsureProcessTerminated in its destructor, and only does so if the handle is still valid. So calling it here leads to some operations on an invalid handle and Windows throws an exception.
Attachment #8800989 - Flags: review?(wmccloskey)
Attachment #8800989 - Flags: review?(wmccloskey) → review+

Comment 2

2 years ago
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e63eae10adb1
Don't double-call EnsureProcessTerminated when killing the GPU process. (bug 1310111, r=billm)

Comment 3

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e63eae10adb1
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox52: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Duplicate of this bug: 1309398
You need to log in before you can comment on or make changes to this bug.