White page when resuming after activity has been destroyed

RESOLVED FIXED in Firefox 52

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: sebastian, Assigned: droeh)

Tracking

unspecified
Firefox 52
All
Android
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, fennec51+, firefox50 unaffected, firefox51 affected, firefox52 verified)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
STR:
* For reproducing this reliably enable developer setting "Don't keep activities"
* Open a website
* Switch to home screen
* Resume browser

Expected result:
* Last opened website should be visible

Actual result:
* White page is displayed
* When page is scrolled some artifacts of the actual page are shown
* After switching tabs the issue is resolved

Video: https://youtu.be/ESR8-V0rKzs
(Reporter)

Comment 1

2 years ago
Nexus 6P, Android 7.0
Assignee: nobody → droeh
tracking-fennec: ? → +
tracking-fennec: + → 51+
(Assignee)

Comment 2

2 years ago
Probably fallout from bug 1305086, looking into it now.
(Assignee)

Comment 3

2 years ago
Jim, it looks like this is caused by your third patch for bug 1291385; I confirmed on a local build that backing it out fixes this issue. Can we safely back it out or do you think doing so will break something else?
Flags: needinfo?(nchen)
You can back out GeckoApp.java and browser.js, but keep the changes in GeckoView.java.
Flags: needinfo?(nchen)
(Assignee)

Comment 5

2 years ago
Created attachment 8806131 [details] [diff] [review]
Set LayerView paint state in GeckoApp.initialize

snorp suggested we could do better than just partially backing out that patch, and kats pointed me in the direction of what was probably happening here. We can fix this by just explicitly setting the LayerView's paint state in GeckoApp.initialize rather than reviving Viewport:Flush. What do you think, Jim?
Attachment #8806131 - Flags: review?(nchen)
Attachment #8806131 - Flags: review?(nchen) → review+

Comment 6

2 years ago
Pushed by droeh@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ef924bafeeda
Set LayerView paint state to PAINT_BEFORE_FIRST in GeckoApp.initialize. r=jchen

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/ef924bafeeda
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox52: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 52
Tested on LG G4 (Android 5.1) using 52.0a1 (2016-11-10)
status-firefox52: fixed → verified
You need to log in before you can comment on or make changes to this bug.