Closed Bug 1310206 Opened 3 years ago Closed 3 years ago

Uplift a few cubeb one-liners to beta

Categories

(Core :: Audio/Video: cubeb, defect, P1)

50 Branch
All
Unspecified
defect

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 + fixed
firefox51 --- fixed
firefox52 --- unaffected

People

(Reporter: padenot, Assigned: padenot)

References

Details

Attachments

(2 files)

There are currently a number of issues in aurora and beta when it comes to Windows:

- bug 1268719, an OOM crash
- bug 1307724 an issue with stereo microphones
- bug 1295193, bug 1300650, two issues related to setups that have different input and output sample rate

We'd like to uplift those fixes, ideally to beta. It's simple changes, that have baked on nightly for some time now.
Assignee: nobody → padenot
Attached patch PatchSplinter Review
Approval Request Comment
[Feature/regressing bug #]: See first comment
[User impact if declined]: OOM crash, audio glitches, audio drift, depending on the user hardware and the system configuration.
[Describe test coverage new/current, TreeHerder]: This is related to specific user hardware that we don't have in automation.
[Risks and why]: This has baked on nightly for some time, confirming that it's fixed with alice and loic (QA volunteer) and several people from the webrtc team.
[String/UUID change made/needed]: none
Attachment #8801111 - Flags: approval-mozilla-beta?
Attachment #8801111 - Flags: approval-mozilla-aurora?
Blocks: 1268719
Rank: 15
Priority: -- → P1
[Tracking Requested - why for this release]:
See Paul's initial description of this bug for details: https://bugzilla.mozilla.org/show_bug.cgi?id=1310206#c0 .  We need to either pref off full duplex for Windows in Beta or uplift the patch on this bug to Beta.
Comment on attachment 8801111 [details] [diff] [review]
Patch

Full duplex audio is planned for 50, patch has been verified by a few users, Aurora51+, Beta50+
Attachment #8801111 - Flags: approval-mozilla-beta?
Attachment #8801111 - Flags: approval-mozilla-beta+
Attachment #8801111 - Flags: approval-mozilla-aurora?
Attachment #8801111 - Flags: approval-mozilla-aurora+
has problems landed on aurora

adding 1310206 to series file
renamed 1310206 -> file_1310206.txt
applying file_1310206.txt
patching file media/libcubeb/src/cubeb_resampler.cpp
Hunk #2 FAILED at 149
1 out of 2 hunks FAILED -- saving rejects to file media/libcubeb/src/cubeb_resampler.cpp.rej
patching file media/libcubeb/src/cubeb_wasapi.cpp
Hunk #4 FAILED at 739
Hunk #5 FAILED at 1016
2 out of 5 hunks FAILED -- saving rejects to file media/libcubeb/src/cubeb_wasapi.cpp.rej
patch failed, unable to continue (try -v)
patch failed, rejects left in working directory
errors during apply, please fix and qrefresh file_1310206.txt
Flags: needinfo?(padenot)
This is the patch rebased from aurora, it's just removing some changes that were
already on aurora.
Sorry about that, I didn't remember we had some code on aurora already.
Flags: needinfo?(padenot) → needinfo?(cbook)
This was done without updating update.sh and adding patches to apply, making further uplifts risky than necessary.  We need to do better than this.
Ritu, we need to back this out from beta. Reports are coming in that specific hardware trigger an issue with this patch in at least bug 1309694 and bug 1312056. We have preffed off duplex on windows for this cycle, so it's not as important anymore.
Flags: needinfo?(rkothari)
(In reply to Paul Adenot (:padenot) from comment #9)
> Ritu, we need to back this out from beta. Reports are coming in that
> specific hardware trigger an issue with this patch in at least bug 1309694
> and bug 1312056. We have preffed off duplex on windows for this cycle, so
> it's not as important anymore.

Sounds good. I am glad we are monitoring the regressions and happy to take the backout in 50.0b10.
Flags: needinfo?(rkothari)
Duplicate of this bug: 1309694
See Also: → 1314316
You need to log in before you can comment on or make changes to this bug.