"Available profiles" Pane in "Switch Profile" dialog too narrow for long profile name

RESOLVED FIXED in seamonkey2.50

Status

enhancement
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: 10981632, Assigned: philip.chee)

Tracking

SeaMonkey 2.40 Branch
seamonkey2.50

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

3 years ago
Posted image switch profile.bmp
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0 SeaMonkey/2.40
Build ID: 20160120202951

Steps to reproduce:

Switch Profile -> 


Actual results:

Cannot see profile names properly


Expected results:

The Switch Profiles dialog is not easy to use. The list titled Available Profiles does not allow the field showing the name of each profiles to be expanded horizontally with the consequence that the name is heavily truncated. When you have several profile names that are very similar it is difficult to tell them apart.

If the window could be resized then the list box could get wider with the window. The edge of the profile name field could be double clicked to extend it to show the longest full name in the list.

While it is possible to hover to see full profile details this seems out of place with user interface standards on Windows wherein it is usually possible to resize the field to get a better view.
Reporter

Updated

3 years ago
Component: General → UI Design
OS: Unspecified → Windows XP
Hardware: Unspecified → x86

Updated

3 years ago
Summary: available profiles window is squashed → "Available profiles" Pane in "Switch Profile" dialog too narrow for long profile name
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
Severity: normal → enhancement
Assignee

Comment 1

3 years ago
This patch does two things:
1.Reduce the padding of the wizard-box. This gives the profile list more horizontal space.
2. Make the profile selection dialog resizable.
Assignee: nobody → philip.chee
Status: NEW → ASSIGNED
Attachment #8807708 - Flags: review?(iann_bugzilla)

Comment 2

3 years ago
Comment on attachment 8807708 [details] [diff] [review]
Patch 1.0 make the profile list wider

>+/* Override global.css */
>+hbox.wizard-box {
>+  padding: 10px 10px 10px 10px;
>+}
Nit: this could just be padding: 10px;

Do we need to look at making the dialog itself any wider?

r/a=me with those addressed
Attachment #8807708 - Flags: review?(iann_bugzilla) → review+
Assignee

Comment 3

3 years ago
(In reply to Ian Neal from comment #2)
> Comment on attachment 8807708 [details] [diff] [review]
> Patch 1.0 make the profile list wider
> 
>> +/* Override global.css */
>> +hbox.wizard-box {
>> +  padding: 10px 10px 10px 10px;
>> +}
> Nit: this could just be padding: 10px;
No it couldn't because it has to override global.css.

> Do we need to look at making the dialog itself any wider?
Not at the moment.

> r/a=me with those addressed
Assignee

Comment 4

3 years ago
Pushed comm-central
http://hg.mozilla.org/comm-central/rev/9ebd91cfe43b
http://hg.mozilla.org/comm-central/rev/9ebd91cfe43b98473430eba05a05467895b01c55
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.50
You need to log in before you can comment on or make changes to this bug.