Regression: uploading photos to dpreview.com community forums broke since 2016-05-10

RESOLVED DUPLICATE of bug 1306472

Status

()

--
major
RESOLVED DUPLICATE of bug 1306472
2 years ago
2 years ago

People

(Reporter: jujjyl, Unassigned)

Tracking

49 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8801480 [details]
dpreview_bisection_log.txt

STR:

1. Create an account/log in at https://www.dpreview.com/
2. Start a new "share photos" forum thread: http://clb.demon.fi/bugs/dpreview/dpreview_1.jpg
3. Choose "Insert image from your computer": http://clb.demon.fi/bugs/dpreview/dpreview_2.jpg and upload a .jpg image.

Observed: The image upload never finishes, but the upload icon keeps spinning on the screen indefinitely: http://clb.demon.fi/bugs/dpreview/dpreview_observed.jpg . No errors are printed on console.

Expected: The image upload should finish and appear on the body of the forum post: http://clb.demon.fi/bugs/dpreview/dpreview_expected.jpg

This used to work on Firefox 48, but Firefox 49 release regressed. Attached a bisection log, which points to this regression range:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=e457582d0089f8efa6b89f112298373aa50e6e5f&tochange=29ee431f39218378889fb821d448487497a0d1fd

Marking this as major since this is a regression that went all the way through to release without being noticed, and because it impacts one of the biggest professional photography communities, and without a workaround, can have a direct impact to people switching away from Firefox.
(Reporter)

Comment 1

2 years ago
Bug 1270349 mentions something about legacy code, so if the case is that dpreview.com was using some legacy feature that bug 1270349 removed/deprecated, then it would be expected that the browser console should post a trail so that dpreview.com developers will have a known way to fix themselves. (not sure if this is the case, but possible(?))
(Reporter)

Updated

2 years ago
Flags: needinfo?(bzbarsky)
(Reporter)

Comment 2

2 years ago
This issue is being discussed at dpreview.com at https://www.dpreview.com/forums/thread/4064719.
Chances are, this is a duplicate of bug 1306472 and its various duplicates.  Is this still an issue now that bug 1268047 has been backed out?  Is the site using jquery fileupload (as I expect)?
Flags: needinfo?(bzbarsky) → needinfo?(jujjyl)
(Reporter)

Comment 4

2 years ago
Oh, splendid timing! Today's Firefox Nightly doesn't work, but building mozilla-central from trunk does work, so looks like bug 1306472 fixes this. I see that the fix was uplifted to mozilla-release, does that mean that Firefox 49 will get a point update to fix, or will the fix roll in to Firefox 50?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(jujjyl)
Resolution: --- → FIXED
Great, thank you for checking that!

I thikn the plan is that if we do a Firefox 49 dot release we will ship the fix in that.  There's a good chance we will in fact do one, both because of this bug and because of one other issue, I'm told.
Blocks: 1268047
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1306472
You need to log in before you can comment on or make changes to this bug.