If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

When switching to full screen, HTML5 video freezes but audio goes on

RESOLVED WONTFIX

Status

()

Core
Audio/Video: Playback
RESOLVED WONTFIX
11 months ago
11 months ago

People

(Reporter: giacecco, Unassigned)

Tracking

49 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 months ago
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160919122641

Steps to reproduce:

On an up to date Fedora 24 running on a Lenovo Thinkpad T450s, without Flash installed, start a YouTube video, e.g. https://www.youtube.com/watch?v=KEbFtMgGhPY or https://www.youtube.com/watch?v=cfudXO_vzWk and then switch to full screen by clicking the dedicated icon overlayed on the video.


Actual results:

The video freezes after less than 1 second, while the audio goes on.

I am currently using Firefox 49.0-2  but I've had this problem for at least two months. It persisted through several updates. Google Chrome does not have the issue.

*Most* YouTube videos are affected, but not all of them. 


Expected results:

The video should have played regularly.
(Reporter)

Updated

11 months ago
Component: Untriaged → General
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Component: General → Audio/Video: Playback
Product: Firefox → Core

Comment 1

11 months ago
Build ID: 20160919122641
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0

Could not reproduce.
(Reporter)

Comment 2

11 months ago
Thanks for checking Yamin. My guess he's that the issue is linked to the drivers for the integrated video card the T450s uses. What hardware have you tried reproducing the issue on? I don't have my laptop with me now otherwise I would give you more information. Can you suggest what debug info I can produce for you? The fact that the same doesn't happen with Chrome suggests that Firefox is doing something differently when switching to full screen.

Comment 3

11 months ago
Lenovo(In reply to giacecco from comment #2)
> Thanks for checking Yamin. My guess he's that the issue is linked to the
> drivers for the integrated video card the T450s uses. What hardware have you
> tried reproducing the issue on? I don't have my laptop with me now otherwise
> I would give you more information. Can you suggest what debug info I can
> produce for you? The fact that the same doesn't happen with Chrome suggests
> that Firefox is doing something differently when switching to full screen.

Lenovo G40-80. Spec: http://psref.lenovo.com/syspool/Sys/PDF/Lenovo%20Laptops/Lenovo%20G40/Lenovo_G40_Platform_Specifications.pdf

Comment 4

11 months ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160920074044

Could not reproduce.

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Could not reproduce.

Updated

11 months ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

11 months ago
Yamin you may have the model that also has the NVIDIA GeForce 820M. My T450s only has the integrated Intel HD Graphics 5500 http://psref.lenovo.com/syspool%5CSys/PDF/ThinkPad/ThinkPad%20T450s/ThinkPad_T450s_Platform_Specifications.pdf I suggest setting this back to unconfirmed until you or someone else can confirm she/he can't reproduce using the HD Graphics 5500 only. 

Alternatively, as suggested already, please suggest some testing I can do / debugging information I can produce for you to evaluate. Thanks.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

11 months ago
... and no Flash plugin active btw, that I am sure also makes a lot of a difference.
(Reporter)

Comment 7

11 months ago
Guys, I have more information for you. I could reproduce the issue as usual, but found two more elements:

a) When full screen, the video re-starts while I move the mouse pointer over the video, and stops again if I stop.

b) I've tried capturing the screen of my laptop using OBS Studio (https://obsproject.com). The video file I've captured does NOT show the issue, as if I could not reproduce the issue, but I did!

Again, Chrome has no issues, so the issue must be somewhere between how Firefox sends full screen video and the Intel drivers.
(Reporter)

Comment 8

11 months ago
Solved by removing - don't ask me why - the xorg-x11-drv-intel package, that apparently is not necessary any more. Inspiration for trying this comes from https://bbs.archlinux.org/viewtopic.php?id=213950 .
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago11 months ago
Resolution: --- → INVALID
(Reporter)

Updated

11 months ago
Resolution: INVALID → WONTFIX
You need to log in before you can comment on or make changes to this bug.