socket.timeout: timed out for fetching hg.mozilla.org fingerprint from http://taskcluster/secrets/v1/secret/project/taskcluster/gecko/hgfingerprint

RESOLVED DUPLICATE of bug 1305095

Status

Release Engineering
General Automation
RESOLVED DUPLICATE of bug 1305095
a year ago
a year ago

People

(Reporter: aryx, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

This happens recently more often. Taskcluster related?

https://treeherder.mozilla.org/logviewer.html#?job_id=5291596&repo=mozilla-central

[taskcluster 2016-10-16 13:22:42.078Z] === Task Starting ===
[setup 2016-10-16T13:22:42.287317Z] run-task started
[chown 2016-10-16T13:22:42.288551Z] recursively changing ownership of /home/worker/workspace to worker:worker
[chown 2016-10-16T13:22:42.288644Z] recursively changing ownership of /home/worker/tooltool-cache to worker:worker
[setup 2016-10-16T13:22:42.288984Z] running as worker:worker
[vcs 2016-10-16T13:22:42.289046Z] fetching hg.mozilla.org fingerprint from http://taskcluster/secrets/v1/secret/project/taskcluster/gecko/hgfingerprint
Traceback (most recent call last):
  File "/home/worker/bin/run-task", line 300, in <module>
    sys.exit(main(sys.argv[1:]))
  File "/home/worker/bin/run-task", line 278, in main
    branch=os.environ.get('GECKO_HEAD_REF'))
  File "/home/worker/bin/run-task", line 96, in vcs_checkout
    res = urllib2.urlopen(FINGERPRINT_URL, timeout=10)
  File "/usr/lib/python2.7/urllib2.py", line 154, in urlopen
    return opener.open(url, data, timeout)
  File "/usr/lib/python2.7/urllib2.py", line 431, in open
    response = self._open(req, data)
  File "/usr/lib/python2.7/urllib2.py", line 449, in _open
    '_open', req)
  File "/usr/lib/python2.7/urllib2.py", line 409, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.7/urllib2.py", line 1227, in http_open
    return self.do_open(httplib.HTTPConnection, req)
  File "/usr/lib/python2.7/urllib2.py", line 1200, in do_open
    r = h.getresponse(buffering=True)
  File "/usr/lib/python2.7/httplib.py", line 1132, in getresponse
    response.begin()
  File "/usr/lib/python2.7/httplib.py", line 453, in begin
    version, status, reason = self._read_status()
  File "/usr/lib/python2.7/httplib.py", line 409, in _read_status
    line = self.fp.readline(_MAXLINE + 1)
  File "/usr/lib/python2.7/socket.py", line 480, in readline
    data = self._sock.recv(self._rbufsize)
socket.timeout: timed out
I'm guessing this is related to bug 1310643?  That connection is local, so it shouldn't time out.
See Also: → bug 1310643
See Also: → bug 1305095
(In reply to Dustin J. Mitchell [:dustin] from comment #1)
> I'm guessing this is related to bug 1310643?  That connection is local, so
> it shouldn't time out.
No, already occurred before Friday evening UTC.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1305095
You need to log in before you can comment on or make changes to this bug.