Closed Bug 1310664 Opened 3 years ago Closed 3 years ago

Add a field to datastore in order to identify crash ping type

Categories

(Cloud Services Graveyard :: Metrics: Pipeline, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ddurst, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fce-active-legacy])

Once we have more types of crash pings than just browser (bug 1293656), we will need to be able to separate those post-submission.
Blocks: 1310673
Blocks: 1310674
Component: Telemetry → Metrics: Pipeline
Product: Toolkit → Cloud Services
whats your timeline on needs David?
Flags: needinfo?(ddurst)
Which datastore are we talking about?

We definitely need to update crash_aggregates, because that drives the crash rate dashboards. I don't know what other datasets exist right now.
No longer blocks: 1310673
Depends on: 1310673
Sorry, bit of a shorthand here, (but I'm glad this came up because I missed a link on the dependency tree).

For this bug, I'm only talking about adding this to the pings (aka storage on S3). Benjamin's concern is addressed in bug 1310680 (and via bug 1310673).

thuelbert -- we're looking to land this this week or next. If I understand it correctly, we are able to do this ourselves without impact on anything else.

Let me know if this is incorrect. Our intention is basically to start landing crash pings with stacks (today) followed by content crash pings (with and without stacks). But we want to make sure we don't disrupt anything in the process.
Flags: needinfo?(ddurst) → needinfo?(thuelbert)
:ddurst you can do that yourselves unless it's a new ping type. And this is not the case from what I understand. The only bit that requires coordination is bug 1310673.
Flags: needinfo?(thuelbert)
I *think* this bug is a dupe of bug 1293656. :ddurst can you confirm that?
Flags: needinfo?(ddurst)
I wouldn't say it's a dupe, but they're close. 1293656 addresses including stack traces in the content crash ping. This addresses needing to differentiate between types of crash pings (of which content crash pings are the first kind since browser crash pings).
Flags: needinfo?(ddurst)
I think that with bug 1310673 being fixed we can close this too, right?
Flags: needinfo?(mdoglio)
This still depends on bug 1293656
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(mdoglio)
Resolution: --- → FIXED
Depends on: 1328657
Whiteboard: [fce-active] → [fce-active-legacy]
Product: Cloud Services → Cloud Services Graveyard
You need to log in before you can comment on or make changes to this bug.