upon "delete attachment" the focus and preview is changed to the next email

RESOLVED DUPLICATE of bug 672753

Status

RESOLVED DUPLICATE of bug 672753
2 years ago
2 years ago

People

(Reporter: oliver.brendel, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupme])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

deleted the attachment of a message (both with delete ... or delete all ...)


Actual results:

the attachment was deleted AND THEN the focus changed to the next (or previous, probably depending on preferences) email, which was then shown in the preview. 


Expected results:

the focus and preview should stay with the email of which the attachment has been deleted
(Reporter)

Comment 1

2 years ago
the same problem occurs when running without anny addons in save mode
(Reporter)

Comment 2

2 years ago
Bug 672753 from 2011 seems to be same. It had been rejected as not solvable. But perhaps 5 years later the discussion should be reopened ? It is a rather annoy8ng bug when one regularly has to delete attachments
(Reporter)

Comment 3

2 years ago
Actually, the last comment in Bug 672753  does not seem to apply anymore : 
-----------------------------
What I see is dependent on sort selection in the message pane.
My normal order is "order received"
In that case, the next message is opened with just a single deletion.
If I sort on date, the message stays open.(imap and pop)

This makes sense, since when you delete an attachment, the whole message must be re-written to the mbox
That 'order received' number changes on the re-write.

I don't think there is anything we could do about that.
But the workaround would seem to be "Don't sort on 'order received'"
-----------------------------------------

I get the problem also when I sort on date (and not order received) and also when sorted on read/unread. And sometimes, because the message switches from unread to read, the message will just disappear down the list of emails and I am left with the next unread email. I will then need to remember sender / date / subject to find the email again ....
(Reporter)

Comment 4

2 years ago
Bug 318954 is also the same phenomenon, with some good explications, but also last comment from 2012, so four years ago. it seems that the problem comes from the action that is taken to delete an attachment, actually the email is deleted and then recreated without attachments. I can see that this should have an effect on the position of the email in the inbox list when ordered by "order received", but not when ordered by "date". A simple re-ordering by date brings the email back into its correct position. 

Perhaps the simplest solution would be that after deleting an attachment, the current sort order of the emails is udapted, e.g. if the emails are sorted by "date", then re-do sorting by date automatically after attachment deletion.
(Reporter)

Comment 5

2 years ago
Actually, to be precise, when emails are sorted by date, only the focus changes when an attachment is deleted ...

Comment 6

2 years ago
This is certainly a reasonable duplicate - if not to one of the bugs you mentioned, then to some other bug. Please pick one :)
Flags: needinfo?(oliver.brendel)
Whiteboard: [dupme]
(Reporter)

Comment 7

2 years ago
It's closest to bug 672753, which had been reported in 2011 and closed in 2013, but with an argument about 
Bug 318954 is about the email moving in the list, which I don't observe anymore.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 672753
(Reporter)

Comment 8

2 years ago
I still get a "Needinfo" flag. Has the info above not been sufficient ?

Updated

2 years ago
Flags: needinfo?(oliver.brendel)
You need to log in before you can comment on or make changes to this bug.