goQuitApplication doesn't: Can't exit from mail

VERIFIED DUPLICATE of bug 12893

Status

SeaMonkey
MailNews: Message Display
P2
major
VERIFIED DUPLICATE of bug 12893
19 years ago
13 years ago

People

(Reporter: Akkana Peck, Assigned: hangas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Exiting from mail creates an editor shell and doesn't exit.  This is because
goQuitApplication() in globalOverlay.xul creates an editor shell (why??) then
tells the newly created editor shell to exit.

Updated

19 years ago
Priority: P3 → P2
Target Milestone: M11

Comment 1

19 years ago
Bill, is this our bug?

Updated

19 years ago
Component: XUL → Front End
Product: Browser → MailNews

Comment 2

19 years ago
No, it's a mail/news thing, I believe.

I've changed the product to MailNews...

Comment 3

19 years ago
No, it's not a mailnews thing. The offending code is in globalOverlay.js, which
is, er, global.

Comment 4

19 years ago
The problem was reported against mail ("Exiting from mail..."), the code in
question is only deployed in MailNews windows (as best I can determine), and it
was authored by a member of the MailNews team.  Regardless of what one chooses
to name the file containing the broken code, it's likely to get fixed sooner if
I do what I can to get it assigned to somebody on that team.

Comment 5

19 years ago
I was thinking that this was part of the general quit/shutdown problem that
you're working on, to which bug 8673 relates.

Updated

19 years ago
Assignee: law → phil

Updated

19 years ago
Assignee: phil → hangas

Comment 6

19 years ago
Reassign to hangas, who apparently authored goQuitApplication in rev 1.3 of that
file.
(Reporter)

Comment 7

19 years ago
I have problems quitting from the browser, too, though not precisely the same
problem.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 8

19 years ago
*** This bug has been marked as a duplicate of 12893 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
Verified as duplicate on 102599.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.