Webextension panel does not auto-resize according to the URLs length

RESOLVED DUPLICATE of bug 1294442

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1294442
2 years ago
a year ago

People

(Reporter: Vasilica Mihasca, QA [away for an extended period of time - please needinfo addonsqa@softvision.ro], Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(firefox49 unaffected, firefox50 verified, firefox51 verified, firefox52 verified)

Details

Attachments

(1 attachment)

Created attachment 8802025 [details]
history-deleter.zip

[Affected versions]:
Firefox 52.0a1 (2016-10-17)
Firefox 51.0a2 (2016-10-17)
Firefox 50.0b7 (20161013141419)


[Affected platforms]:
Windows 10 64-bit
Ubuntu 16.04 32-bit

[Steps to reproduce]:
1.Launch Firefox with clean profile.
2.Install the attached webextension as a temporary add-on:
3.Perform a google search and navigate a bit through google images in order to gather some browsing history.


[Expected Results]:
The entire content is correctly displayed in the panel.

[Actual Results]:
When the URLs are too long, the webextension panel does not auto-resize according to the links length and the last 5 visited sites are not entirely displayed: http://screencast.com/t/TImjHQor06

[Regression Range]:
Last good revision: dd0771829dc90fdc6c9d19f4884ebc7c340f3beb
First bad revision: bd503b1c36f3d07556c305fa1f0e34ed8a6424db
Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=dd0771829dc90fdc6c9d19f4884ebc7c340f3beb&tochange=bd503b1c36f3d07556c305fa1f0e34ed8a6424db

I suspect that this issue was regressed by Bug 1215025.

[Additional notes]:
- Also see the github bug: https://github.com/mdn/webextensions-examples/issues/90
- Firefox 49.0.1 (20160922113459) is not affected.
Flags: needinfo?(kmaglione+bmo)
This is another side-effect of bug 1294442. The size calculation code reflows the document to its preferred width, but doesn't take into account our maximum height. So while the document height is restricted to 600px, it thinks it's tall enough to display its entire content.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → DUPLICATE
Duplicate of bug: 1294442
Updating status for 50, 51 and 52 from bug 1294442 that this one is a dup of.
status-firefox50: affected → verified
status-firefox51: affected → verified
status-firefox52: affected → verified
You need to log in before you can comment on or make changes to this bug.