treeherder try build link returns InvalidRequestArguments

RESOLVED DUPLICATE of bug 1158283

Status

Tree Management
Treeherder
RESOLVED DUPLICATE of bug 1158283
2 years ago
2 years ago

People

(Reporter: keeler, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
STR:

visit https://treeherder.mozilla.org/#/jobs?repo=try&revision=e9381012847d&selectedJob=29296600
click the failed Cpp unit test job
click the link next to "Build" in the pane that comes up

Expected results: a page with links to various artifacts

Actual results:

{
  "code": "InvalidRequestArguments",
  "message": "Invalid URL patterns:\nURL parameter 'name' given as '' must match regular expression: '/^[\\x20-\\x7e]+$/'\n----\nerrorCode:  InvalidRequestArguments\nstatusCode: 400\nrequestInfo:\n  method:   getArtifact\n  params:   {\"0\":\"\",\"taskId\":\"B4KNsbdKTceHDB0UvGUfFQ\",\"runId\":\"0\",\"name\":\"\"}\n  payload:  {}\n  time:     2016-10-18T17:01:53.195Z\ndetails:\n{\n  \"errors\": [\n    \"URL parameter 'name' given as '' must match regular expression: '/^[\\\\x20-\\\\x7e]+$/'\"\n  ]\n}",
  "requestInfo": {
    "method": "getArtifact",
    "params": {
      "0": "",
      "taskId": "B4KNsbdKTceHDB0UvGUfFQ",
      "runId": "0",
      "name": ""
    },
    "payload": {},
    "time": "2016-10-18T17:01:53.195Z"
  },
  "details": {
    "errors": [
      "URL parameter 'name' given as '' must match regular expression: '/^[\\x20-\\x7e]+$/'"
    ]
  }
}
Seems to be broken for all tc-based jobs (or at least, all tc-based jobs in this one particular try push... haven't checked elsewhere). I'm not sure offhand if this is a Treeherder bug about not sending all of the information needed to Taskcluster, or if this is just Taskcluster itself being broken.
Flags: needinfo?(wlachance)
Flags: needinfo?(emorley)
Appears to affect pushes other than that one, on try and elsewhere.
Buildbot jobs are still fine, so I don't think this is a Treeherder issue. Greg, could you get someone to investigate this?

Here's the URL that doesn't work: https://queue.taskcluster.net/v1/task/B4KNsbdKTceHDB0UvGUfFQ/runs/0/artifacts/
Flags: needinfo?(wlachance)
Flags: needinfo?(garndt)
Flags: needinfo?(emorley)

Comment 4

2 years ago
This isn't a taskcluster bug, the "directory URLs" are derived, but that only works if linking to a system that offers directory indexes.

Short term the build link should be disabled for !buildbot (this is bug 1158283).

Longer term we should actually add build directory as a specific job_detail (or similar) and get taskcluster/... to populate it with some artifact inspector type URL that lists all artifacts associated with a job.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(garndt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1158283
You need to log in before you can comment on or make changes to this bug.