Closed Bug 1311116 Opened 3 years ago Closed 3 years ago

Reduce the default output from the marionette instance in debug builds

Categories

(Testing :: Marionette, defect)

defect
Not set

Tracking

(firefox52 fixed, firefox53 fixed)

RESOLVED FIXED
mozilla53
Tracking Status
firefox52 --- fixed
firefox53 --- fixed

People

(Reporter: jdm, Assigned: ato)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

As a user of debug builds to run tests, the output from the marionette client isn't useful to me, but there's a lot of it and it's on by default: https://dxr.mozilla.org/mozilla-central/rev/dc89484d4b45abf442162e5ea2dd46f9de40197d/testing/marionette/components/marionettecomponent.js#70 . Could we reverse this, so that the developers that care about the marionette debug output could enable a preference instead?
Usually you can specify -vv on the command line to enable tracing output for Marionette. I think we had it enabled by default for debug builds in early stages of Marionette for a better debugging experience.

Andreas implemented that and I would give him the word here...
Flags: needinfo?(ato)
I think I’m fine with raising the default logging level of debug builds to Log.Level.Info.  We can configure the try jobs, if we decide we need it in the future, to use Log.Level.Debug by setting the marionette.logging preference to "debug".
Flags: needinfo?(ato)
Assignee: nobody → ato
Status: NEW → ASSIGNED
Comment on attachment 8809434 [details]
Bug 1311116 - Use info level logging in Marionette debug builds;

https://reviewboard.mozilla.org/r/92028/#review92280
Attachment #8809434 - Flags: review?(dburns) → review+
FYI the tracing output of Marionette was totally helpful for me in the last couple of weeks to actually nail down intermittent failures on autoland and m-c. Especially those which do not appear that often. Seeing now that all the output will go away will make it certainly harder to find the root cause.
Josh, was your request more for local builds or also related to results on Treeherder? If it's only for local we should fix our command line for Taskcluster and buildbot and get -vv added.
Flags: needinfo?(josh)
Local builds.
Flags: needinfo?(josh)
Ok, that sounds fine. Andreas, I would suggest that at the same time we should get this option added to mozharness builds so that we can keep tracing enabled for now, which is very helpful as mentioned above.
Flags: needinfo?(ato)
Blocks: 1317330
(In reply to Henrik Skupin (:whimboo) from comment #8)
> Ok, that sounds fine. Andreas, I would suggest that at the same time we
> should get this option added to mozharness builds so that we can keep
> tracing enabled for now, which is very helpful as mentioned above.

Yes.  Filed https://bugzilla.mozilla.org/show_bug.cgi?id=1317330.
Flags: needinfo?(ato)
Pushed by atolfsen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1c001b02b278
Use info level logging in Marionette debug builds; r=automatedtester
https://hg.mozilla.org/mozilla-central/rev/1c001b02b278
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
Attached patch 1311116-aurora.diff (obsolete) — Splinter Review
Attached a version of the patch suitable for uplift to aurora. Try run at [1]. (Assuming the try run agrees) this fixes bug 1273470 on aurora.

[1] https://treeherder.mozilla.org/#/jobs?repo=try&revision=59b6bda4fa1e108e9b30f4d545b0014de87473ee
Blocks: 1273470
Comment on attachment 8826605 [details] [diff] [review]
1311116-aurora.diff

I don't have issues grafting the original changeset to aurora. So this additional patch is not necessary.
Attachment #8826605 - Attachment is obsolete: true
Please uplift this test-only patch to aurora. Thanks.
Whiteboard: [checkin-needed-aurora]
You need to log in before you can comment on or make changes to this bug.