Regression: Preferences favicon flickers (moves slightly) on background tab while hovering over it

RESOLVED WORKSFORME

Status

()

Firefox
Theme
RESOLVED WORKSFORME
2 years ago
12 days ago

People

(Reporter: Mehmet, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8802283 [details]
preference_icon_flicker.mov

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:52.0) Gecko/20100101 Firefox/52.0
Build ID: 20161018030211

Steps to reproduce:

52.0a1 (2016-10-18) (64-bit)
Mac OS 10.11.6

STR:
1.) open two tabs
2.) in the right tab open the preferences via about:preferences
3.) click on the first tab on the left side, so that the tab with the preferences is in the background
4.) hover over the background preferences tab


Actual results:

Preferences favicon flickers on the background tab.


Expected results:

It should not flicker.

It is a regression. It works fine in Firefox stable.

A screencast is attached.
(Reporter)

Updated

2 years ago
Component: Untriaged → Theme

Comment 1

2 years ago
Can you find a regression window?
Flags: needinfo?(mehmet.sahin)
(Reporter)

Comment 2

2 years ago
(In reply to :Gijs Kruitbosch from comment #1)
> Can you find a regression window?

The regression range is between the following two builds:

good build: 51.0a1 (2016-08-19)

bad build: 51.0a1 (2016-08-20)
Flags: needinfo?(mehmet.sahin)

Comment 3

2 years ago
(In reply to Mehmet from comment #2)
> (In reply to :Gijs Kruitbosch from comment #1)
> > Can you find a regression window?
> 
> The regression range is between the following two builds:
> 
> good build: 51.0a1 (2016-08-19)
> 
> bad build: 51.0a1 (2016-08-20)

Can you use mozregression or similar to narrow this down further to a particular branch build? https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cf06fbc831754e54c6abb71d3136597488a530e0&tochange=f97a056ae6235de7855fd8aaa04fb1c8d183bd06 is still a really large range.
Flags: needinfo?(mehmet.sahin)
(Reporter)

Comment 4

2 years ago
(In reply to :Gijs Kruitbosch from comment #3)
> (In reply to Mehmet from comment #2)
> > (In reply to :Gijs Kruitbosch from comment #1)
> > > Can you find a regression window?
> > 
> > The regression range is between the following two builds:
> > 
> > good build: 51.0a1 (2016-08-19)
> > 
> > bad build: 51.0a1 (2016-08-20)
> 
> Can you use mozregression or similar to narrow this down further to a
> particular branch build?
> https://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=cf06fbc831754e54c6abb71d3136597488a530e0&tochange=f97a
> 056ae6235de7855fd8aaa04fb1c8d183bd06 is still a really large range.

Sorry, I am not a developer. So I do not have Xcode installed. Does mozregression also work without it?

Comment 5

2 years ago
(In reply to Mehmet from comment #4)
> (In reply to :Gijs Kruitbosch from comment #3)
> > (In reply to Mehmet from comment #2)
> > > (In reply to :Gijs Kruitbosch from comment #1)
> > > > Can you find a regression window?
> > > 
> > > The regression range is between the following two builds:
> > > 
> > > good build: 51.0a1 (2016-08-19)
> > > 
> > > bad build: 51.0a1 (2016-08-20)
> > 
> > Can you use mozregression or similar to narrow this down further to a
> > particular branch build?
> > https://hg.mozilla.org/mozilla-central/
> > pushloghtml?fromchange=cf06fbc831754e54c6abb71d3136597488a530e0&tochange=f97a
> > 056ae6235de7855fd8aaa04fb1c8d183bd06 is still a really large range.
> 
> Sorry, I am not a developer. So I do not have Xcode installed. Does
> mozregression also work without it?

Yes! On mac, you should be able to just execute the following from terminal.app:

pip install mozregression

mozregression --good cf06fbc831754e54c6abb71d3136597488a530e0 --bad 056ae6235de7855fd8aaa04fb1c8d183bd06


and eventually it'll spit out a range involving fx-team or mozilla-inbound or something like that. See http://mozilla.github.io/mozregression/ for more info.
(Reporter)

Comment 6

2 years ago
(In reply to :Gijs Kruitbosch from comment #5)
> Yes! On mac, you should be able to just execute the following from
> terminal.app:
> 
> pip install mozregression
> 
> mozregression --good cf06fbc831754e54c6abb71d3136597488a530e0 --bad
> 056ae6235de7855fd8aaa04fb1c8d183bd06
> 
> 
> and eventually it'll spit out a range involving fx-team or mozilla-inbound
> or something like that. See http://mozilla.github.io/mozregression/ for more
> info.

Thanks. Here is the output:

INFO: Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1295818

Comment 7

2 years ago
(In reply to Mehmet from comment #6)
> (In reply to :Gijs Kruitbosch from comment #5)
> > Yes! On mac, you should be able to just execute the following from
> > terminal.app:
> > 
> > pip install mozregression
> > 
> > mozregression --good cf06fbc831754e54c6abb71d3136597488a530e0 --bad
> > 056ae6235de7855fd8aaa04fb1c8d183bd06
> > 
> > 
> > and eventually it'll spit out a range involving fx-team or mozilla-inbound
> > or something like that. See http://mozilla.github.io/mozregression/ for more
> > info.
> 
> Thanks. Here is the output:
> 
> INFO: Looks like the following bug has the changes which introduced the
> regression:
> https://bugzilla.mozilla.org/show_bug.cgi?id=1295818

Did it also output a pushlog URL? What's the pushlog URL?
(Reporter)

Comment 8

2 years ago
(In reply to :Gijs Kruitbosch from comment #7)
> Did it also output a pushlog URL? What's the pushlog URL?

I ran it again: Here is the pushlog https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5efdbc22fb511281da3ff3f73abe024769fd55e7&tochange=15405ca22e649c31eeb3ce39c1ce2710ad044e8f



14:38.59 INFO: Narrowed inbound regression window from [28eb1eab, 15405ca2] (3 revisions) to [5efdbc22, 15405ca2] (2 revisions) (~1 steps left)
14:38.59 INFO: Oh noes, no (more) inbound revisions :(
14:38.59 INFO: Last good revision: 5efdbc22fb511281da3ff3f73abe024769fd55e7
14:38.59 INFO: First bad revision: 15405ca22e649c31eeb3ce39c1ce2710ad044e8f
14:38.59 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5efdbc22fb511281da3ff3f73abe024769fd55e7&tochange=15405ca22e649c31eeb3ce39c1ce2710ad044e8f

14:40.11 INFO: Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1295818

Comment 9

2 years ago
So the interesting thing is that I couldn't reproduce this locally. Does this reproduce on a clean profile? Can you attach your about:support (help > troubleshooting information) ?

I'm also struggling to see how this is related to the change in question... :emilio or :heycam, any chance you have ideas?
Flags: needinfo?(ecoal95)
Flags: needinfo?(cam)

Updated

2 years ago
Summary: Regression: Preferences favicon flickers on background tab while hovering over it → Regression: Preferences favicon flickers (moves slightly) on background tab while hovering over it
FWIW, I also can't reproduce (though I'm not on OSX).

I doubt that the regressor is bug 1295818 since it was purely refactoring (though maybe is some kind of layout timing issue uncovered by this? That'd be extremely surprising).
Flags: needinfo?(ecoal95)
(Reporter)

Comment 11

2 years ago
(In reply to :Gijs Kruitbosch from comment #9)
> So the interesting thing is that I couldn't reproduce this locally. Does
> this reproduce on a clean profile? Can you attach your about:support (help >
> troubleshooting information) ?
> 
> I'm also struggling to see how this is related to the change in question...
> :emilio or :heycam, any chance you have ideas?

This is also happening in Safe-Mode.

Maybe interesting: I am using a Non-Retina Mac (MacBook Air 11" 2012).

Application Basics
------------------

Name: Firefox
Version: 52.0a1
Build ID: 20161019030208
Update Channel: nightly
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:52.0) Gecko/20100101 Firefox/52.0
OS: Darwin 15.6.0
Multiprocess Windows: 1/1 (Enabled by default)
Safe Mode: false

Crash Reports for the Last 3 Days
---------------------------------

All Crash Reports

Extensions
----------

Name: Adblock Plus
Version: 2.7.3
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: FlyWeb
Version: 1.0.0
Enabled: true
ID: flyweb@mozilla.org

Name: Form Autofill
Version: 1.0
Enabled: true
ID: formautofill@mozilla.org

Name: Multi-process staged rollout
Version: 1.4
Enabled: true
ID: e10srollout@mozilla.org

Name: Pocket
Version: 1.0.5
Enabled: true
ID: firefox@getpocket.com

Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org

Graphics
--------

Features
Compositing: OpenGL
Asynchronous Pan/Zoom: wheel input enabled
WebGL Renderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
WebGL2 Renderer: Intel Inc. -- Intel HD Graphics 4000 OpenGL Engine
Hardware H264 Decoding: Yes
Audio Backend: audiounit
GPU #1
Active: Yes
Vendor ID: 0x8086
Device ID: 0x0166

Diagnostics
AzureCanvasAccelerated: 1
AzureCanvasBackend: skia
AzureContentBackend: skia
AzureFallbackCanvasBackend: none
TileHeight: 512
TileWidth: 512





Important Modified Preferences
------------------------------

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.frecency_experiment: 3
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.sessionstore.upgradeBackup.latestBuildID: 20161019030208
browser.startup.homepage: about:home
browser.startup.homepage_override.buildID: 20161019030208
browser.startup.homepage_override.mstone: 52.0a1
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 3
browser.urlbar.lastSuggestionsPromptDate: 20160806
browser.urlbar.suggest.searches: true
browser.urlbar.userMadeSearchSuggestionsChoice: true
dom.apps.lastUpdate.buildID: 20160701030201
dom.apps.lastUpdate.mstone: 50.0a1
dom.apps.reset-permissions: true
extensions.lastAppVersion: 52.0a1
general.autoScroll: false
gfx.blacklist.direct2d.failureid: FEATURE_FAILURE_DL_BLACKLIST_g984
media.benchmark.vp9.fps: 91
media.benchmark.vp9.versioncheck: 1
media.gmp-gmpopenh264.abi: x86_64-gcc3-u-i386-x86_64
media.gmp-gmpopenh264.enabled: false
media.gmp-gmpopenh264.lastUpdate: 1471420876
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20161019030208
media.gmp-manager.lastCheck: 1476910041
media.gmp-widevinecdm.abi: x86_64-gcc3-u-i386-x86_64
media.gmp-widevinecdm.enabled: false
media.gmp-widevinecdm.lastUpdate: 1471848340
media.gmp-widevinecdm.version: 1.4.8.903
media.gmp.storage.version.observed: 1
network.cookie.cookieBehavior: 3
network.cookie.prefsMigrated: true
network.predictor.cleaned-up: true
places.database.lastMaintenance: 1476425825
places.history.expiration.transient_current_max_pages: 122334
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true
plugin.state.default browser: 0
plugin.state.eppex plugin: 0
plugin.state.flash: 0
privacy.sanitize.sanitizeOnShutdown: true
security.sandbox.content.tempDirSuffix: {841b256e-5658-914d-a24d-2ed331b6c8ce}
services.sync.declinedEngines:
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1475772591

Important Locked Preferences
----------------------------

Places Database
---------------

JavaScript
----------

Incremental GC: true

Accessibility
-------------

Activated: false
Prevent Accessibility: 0

Library Versions
----------------

NSPR
Expected minimum version: 4.13
Version in use: 4.13

NSS
Expected minimum version: 3.28 Beta
Version in use: 3.28 Beta

NSSSMIME
Expected minimum version: 3.28 Beta
Version in use: 3.28 Beta

NSSSSL
Expected minimum version: 3.28 Beta
Version in use: 3.28 Beta

NSSUTIL
Expected minimum version: 3.28 Beta
Version in use: 3.28 Beta

Experimental Features
---------------------

Sandbox
-------

Content Process Sandbox Level: 2
(Reporter)

Comment 12

2 years ago
Friendly ping. Any news on this? How can I help further? May be you can provide me a build without the two changes from https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=5efdbc22fb511281da3ff3f73abe024769fd55e7&tochange=15405ca22e649c31eeb3ce39c1ce2710ad044e8f so that I can check it. Thanks.

Comment 13

2 years ago
I can reproduce on my retina mac by setting layout.css.devPixelsPerPx to 1.0 and using OS X's accessibility zoom to zoom in so I can actually see what's going on.

Emilio, any chance you can investigate what's going on that way?
Flags: needinfo?(ecoal95)
(In reply to :Gijs Kruitbosch from comment #13)
> I can reproduce on my retina mac by setting layout.css.devPixelsPerPx to 1.0
> and using OS X's accessibility zoom to zoom in so I can actually see what's
> going on.
> 
> Emilio, any chance you can investigate what's going on that way?

I haven't been able to reproduce doing the same on Linux (also on a HiDPI machine), and I don't have any OSX machine to investigate this. It seems that the nsStyleChangeList patch is really unlikely to be the regressor, so another regression window with the new STR would be really helpful.
Flags: needinfo?(ecoal95)
(Reporter)

Comment 15

11 months ago
Seems to be fixed in latest Canary. Closing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

11 months ago
Flags: needinfo?(mehmet.sahin)
Flags: needinfo?(cam)
You need to log in before you can comment on or make changes to this bug.