Wasm baseline: OutOfLineTruncateF32OrF64ToI32.off is unused on OSX arm build.

RESOLVED DUPLICATE of bug 1277011

Status

()

Core
JavaScript Engine: JIT
P3
normal
RESOLVED DUPLICATE of bug 1277011
a year ago
a year ago

People

(Reporter: arai, Assigned: lth)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 affected)

Details

(Reporter)

Description

a year ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=41dcef9b2151&selectedJob=29459973

> /builds/slave/try_m64-d_sm-arm-sim-osx-00000/src/js/src/asmjs/WasmBaselineCompile.cpp:2729:20: error: private field 'off' is not used [-Werror,-Wunused-private-field]
>         TrapOffset off;
>                    ^
> 1 error generated.
(Assignee)

Comment 1

a year ago
I'll take this for now; I'm implementing the ARM back-end anyhow.
Assignee: nobody → lhansen
Blocks: 1277011
Component: JavaScript Engine → JavaScript Engine: JIT
Priority: -- → P3
Summary: OutOfLineTruncateF32OrF64ToI32.off is unused on OSX arm build. → Wasm baseline: OutOfLineTruncateF32OrF64ToI32.off is unused on OSX arm build.
(Assignee)

Comment 2

a year ago
Fix will be rolled into the ARM patch.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1277011
You need to log in before you can comment on or make changes to this bug.