If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Misleading error "c is not a registered protocol" when accessing chome://

VERIFIED FIXED in mozilla1.0

Status

()

Core
Document Navigation
--
trivial
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: Matthew Wilson, Assigned: Adam Lock)

Tracking

Trunk
mozilla1.0
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt3])

Attachments

(1 attachment)

986 bytes, patch
Chak Nanga
: review+
rpotts (gone)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

After mis-typing a URL so that it began with "chome://" instead of "chrome://",
the error message reported was "c is not a registered protocol"; i.e. only the
first character of the incorrect protocol was reported.

Reproducible: Always
Steps to Reproduce:
Type 'chome://' in the URL bar (or any non-registered protocol).

Actual Results:  The error message shows only the first character of the
incorrect protocol.

Expected Results:  The full protocol name should be displayed.

Comment 1

16 years ago
-> docshell
Assignee: new-network-bugs → adamlock
Component: Networking → Embedding: Docshell
QA Contact: benc → adamlock
*** Bug 131285 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
qa to me.
Sigh. I really wanted error messages to be robust for mozilla 1.0, but there are
so many of these getting through...

I've seen this as well in 0.9.9.
Keywords: mozilla1.0, nsbeta1
QA Contact: adamlock → benc
(Assignee)

Comment 4

16 years ago
appstrings.properties appears to be using a lower-case %s throughout when - at
least for this instance - it should be using uppercase %S. Most of the other
strings are processed in nsWebShell which calls snprintf for itself, but in this
instance docshell is calling nsIStringBundle::FormatStringFromName which expects
only unichar strings.

Patch follows.
(Assignee)

Comment 5

16 years ago
Created attachment 76772 [details] [diff] [review]
Patch uses %S

Reviews please.
(Assignee)

Comment 6

16 years ago
We're in localization lockdown, but it might be possible to sneak this into 1.0,
so I'll mark it as such for the time being.
Target Milestone: --- → mozilla1.0

Updated

16 years ago
Attachment #76772 - Flags: review+

Comment 7

16 years ago
Comment on attachment 76772 [details] [diff] [review]
Patch uses %S

r=chak
(Assignee)

Comment 8

16 years ago
Lining this up to go in 1.0 if possible. Waiting on the sr but pushing it
through as quickly as possible for consideration.

Summary - very low risk, visible impact

Comment 9

16 years ago
Comment on attachment 76772 [details] [diff] [review]
Patch uses %S

sr=rpotts@betscape.com
Attachment #76772 - Flags: superreview+

Comment 10

16 years ago
Comment on attachment 76772 [details] [diff] [review]
Patch uses %S

a=asa (on behalf of drivers) for checkin to the 1.0 trunk
Attachment #76772 - Flags: approval+
(Assignee)

Comment 11

16 years ago
Lori, can you add your approval as far as localization is concerned? 

Nominate for adt1.0.0+.

Low risk, big impact.
Keywords: adt1.0.0

Comment 12

16 years ago
a=UI
adding impact status. This bug prevents users from figuring out what to do when
they make a typo in the URL field. 
cc'ing mcarlson for localization approval 
Whiteboard: [adt2]

Comment 13

16 years ago
adt1.0.0+ (on ADT's behalf) approval for checkin to 1.0, pending L10N approval.
Changing ADT3
Keywords: adt1.0.0 → adt1.0.0-
Whiteboard: [adt2] → [adt3]

Comment 14

16 years ago
meant "+" ... mia culpa.
Keywords: adt1.0.0- → adt1.0.0+

Comment 15

16 years ago
Can you please check in this change today. l10n approved for check in today. thanks
(Assignee)

Comment 16

16 years ago
1.0 is branching at this moment. I have asked for re-approval and assuming it is
given the checkin should go in when the tree has reopened (which will be
tomorrow for me)
(Assignee)

Comment 17

16 years ago
Fix checked into trunk, still waiting for branch approval
(Assignee)

Comment 18

16 years ago
Fix checked into branch
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 19

16 years ago
adding fixed1.0.0 keyword (branch resolution). This bug has comments saying it
was fixed on the 1.0 branch and a bonsai checkin comment that agrees. To verify
the bug has been fixed on the 1.0 branch please replace the fixed1.0.0 keyword
with verified1.0.0.
Keywords: fixed1.0.0
*** Bug 155257 has been marked as a duplicate of this bug. ***

Comment 21

15 years ago
VERIFIED/branch - Netscape 7.0
VERIFIED/trunk - via Mozilla 1.1
allplats
Status: RESOLVED → VERIFIED
Keywords: fixed1.0.0 → verified1.0.0
You need to log in before you can comment on or make changes to this bug.