Closed Bug 1311442 Opened 3 years ago Closed 3 years ago

remove /home/worker/workspace cache from marionette-harness jobs

Categories

(Firefox Build System :: Task Configuration, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED
mozilla52

People

(Reporter: jmaher, Unassigned)

References

Details

Attachments

(1 file)

in trying to fix up bug 1303543 and bug 1304930, we determined that the worker UID for /home/worker/workspace (the branch specific cache) was 500, but getting permission denied when the worker UID==1000.  While we are not sure this is the cause, it does look suspicious.

The goal here is to disable the cache for this specific job- the UID's are different because this job uses desktop-build as a docker image instead of desktop-test.
Comment on attachment 8802589 [details]
Bug 1311442 - remove /home/worker/workspace cache from marionette-harness jobs.

https://reviewboard.mozilla.org/r/86952/#review85968

::: taskcluster/ci/marionette-harness/kind.yml
(Diff revision 1)
>                  JOB_SCRIPT: "taskcluster/scripts/tester/harness-test-linux.sh"
>                  MOZHARNESS_SCRIPT: "testing/mozharness/scripts/marionette_harness_tests.py"
>                  TOOLS_DISABLE: "true"
>                  TOOLTOOL_REPO: "https://github.com/mozilla/build-tooltool"
>                  TOOLTOOL_REV: "master"
> -            artifacts:

I think that you want this to stay, these are artifacts that will get uploaded.

It appears that the stuff you want to remove is from the transforms used on this task that adds the cache.
Attachment #8802589 - Flags: review?(garndt) → review-
Comment on attachment 8802589 [details]
Bug 1311442 - remove /home/worker/workspace cache from marionette-harness jobs.

https://reviewboard.mozilla.org/r/86952/#review85982
Attachment #8802589 - Flags: review?(garndt) → review+
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/33953c4c3351
remove /home/worker/workspace cache from marionette-harness jobs. r=garndt
https://hg.mozilla.org/mozilla-central/rev/33953c4c3351
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Duplicate of this bug: 1303543
Duplicate of this bug: 1304930
Product: TaskCluster → Firefox Build System
You need to log in before you can comment on or make changes to this bug.