Closed Bug 1311460 Opened 3 years ago Closed 3 years ago

--enable-gamepad by default on Tier3 platforms

Categories

(Firefox Build System :: General, defect)

Unspecified
FreeBSD
defect
Not set

Tracking

(firefox52 fixed)

RESOLVED FIXED
mozilla52
Tracking Status
firefox52 --- fixed

People

(Reporter: jbeich, Unassigned)

References

Details

Attachments

(1 file)

After Firefox OS was downgraded to Tier3 support --disable-gamepad is no longer tested on Treeherder which leads to bustages like bug 1310904. Fixing them isn't always trivial. As stub backend works fine, let's use it by default. Later, the option can be garbage collected or turned into a pref in about:config.
Comment on attachment 8802607 [details]
Bug 1311460 - Enable MOZ_GAMEPAD on Tier3 platforms by default.

https://reviewboard.mozilla.org/r/86968/#review86012

Thanks! As a followup what we should probably just do is make `--disable-gamepad` set `MOZ_GAMEPAD_BACKEND=stub`, then we could remove `MOZ_GAMEPAD` entirely. If you want to make the former happen in this patch that'd be fine (it should only be another line or two of code). If not we can do it in another bug.
Attachment #8802607 - Flags: review?(ted) → review+
Increasing scope may lead to a mistake. So, I'm leaving it up to build peers.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cc5d68a2fcf8
Enable MOZ_GAMEPAD on Tier3 platforms by default. r=ted
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/cc5d68a2fcf8
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla52
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.