When apprunner is used as a rendering engine it hiccups badly on unresolve entities.

VERIFIED WORKSFORME

Status

()

Core
XML
P3
major
VERIFIED WORKSFORME
19 years ago
10 years ago

People

(Reporter: Brad Neuberg, Assigned: Nisheeth Ranjan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

19 years ago
I have been experimenting with using apprunner as a rendering engine.  I run:
apprunner -chrome chrome:/test/HelloWorld.xul
where I have created a HelloWorld.xul file in the chrome directory under a test
directory:
HelloWorld.xul:
<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>

<window id="main-window" xmlns:html="http://www.w3.org/TR/REC-html40"

xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"
			  title="&badentity;"
			  width="640" height="480">

</window>

Notice that in the title attribute I have an entity named badentity.  If I run
apprunner with this example XUL file it completely crashes and just opens a tiny
little window in the upper left corner of the screen (i.e. it renders absolutely
nothing and just makes a tiny window).  It is dangerous that apprunner crashes
for unresolved entities because a large app written in XUL probably has hundreds
of entities, and one unresolved entity shouldn't bring down the whole system.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Target Milestone: M12
(Assignee)

Comment 1

19 years ago
Accepting bug and setting milestone to M12...
(Assignee)

Updated

19 years ago
Summary: When apprunner is used as a rendering engine it hiccups badly on unresolve entities. → [DOGFOOD] When apprunner is used as a rendering engine it hiccups badly on unresolve entities.
(Assignee)

Comment 2

19 years ago
I think this qualifies as a DOGFOOD bug.
(Assignee)

Comment 3

19 years ago
*** Bug 11562 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Whiteboard: [PDT-]

Comment 4

19 years ago
We need this for beta, but not dogfood, putting on PDT- radar.
(Assignee)

Comment 5

19 years ago
Move non-PDT+ bugs to M13...
(Assignee)

Updated

18 years ago
Target Milestone: M13 → M16
(Assignee)

Comment 6

18 years ago
Moving non beta-stoppers to M16...

Comment 7

18 years ago
Putting dogfood in the keyword field.
Keywords: dogfood

Updated

18 years ago
Summary: [DOGFOOD] When apprunner is used as a rendering engine it hiccups badly on unresolve entities. → When apprunner is used as a rendering engine it hiccups badly on unresolve entities.
(Assignee)

Comment 8

18 years ago
This no longer happens in the latest builds.  Marking worksforme.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
Adding 'verifyme' keyword
Keywords: verifyme

Updated

18 years ago
QA Contact: chrisd → petersen

Comment 10

18 years ago
Marking verified in the Sept 5th build.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.