Enter dormant to release decoder resources when playback is paused for some amount of time

RESOLVED DUPLICATE of bug 1311872

Status

()

Core
Audio/Video: Playback
P3
normal
RESOLVED DUPLICATE of bug 1311872
2 years ago
2 years ago

People

(Reporter: jwwang, Assigned: jwwang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

2 years ago
Chances are the user has moved focus away from the media element. We can tell MDSM to enter dormant to release memory or hardware resources. When the user wants to play again, MDSM will exit dormant and seek to the current position to resume playback without causing noticeable effects to the user provided that seek is fast enough.

We will also add telemetry for tweaking pause timeout in next bugs to strive for best user experience.
(Assignee)

Updated

2 years ago
Assignee: nobody → jwwang
Blocks: 1286129
Priority: -- → P3
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1311872
You need to log in before you can comment on or make changes to this bug.