Closed Bug 1311615 Opened 4 years ago Closed 4 years ago

Building with gyp should copy headers, libs, executables to the right directory

Categories

(NSS :: Build, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ttaubert, Assigned: ttaubert)

References

Details

Currently, we copy libraries and executables to ../dist/$OBJDIR/{bin,lib}/ with a few calls to find, in build.sh. Header files aren't copied at all. We should restore the current structure we get when using make.

(Also, the find commands don't work on OS X.)
Blocks: 1237872
(In reply to Tim Taubert [:ttaubert] from comment #1)
> https://nss-dev.phacility.com/D104

is it expected that this link leads to a login page ?
Yeah, we're still working on a proper integration of Phabricator, unfortunately. Here's the patch:

https://gist.github.com/ttaubert/73d7c9133368c7545f624617d75aad1f
bug 1308463 was intended to cover this, but we can just make that about .chk files.
(In reply to Ted Mielczarek [:ted.mielczarek] from comment #4)
> bug 1308463 was intended to cover this, but we can just make that about .chk
> files.

SGTM, we definitely should move that into gyp.
This is going to muck up my Firefox build integration a bit, I special-case copies that go to `$PRODUCT_DIR/dist` to convert them to `EXPORTS`:
http://hg.mozilla.org/users/tmielczarek_mozilla.com/mc/file/51db8bc7f380/python/mozbuild/mozbuild/frontend/gyp_reader.py#l98
What's the best way to handle this? Do you want to adapt gyp_reader.py after NSS merges? Can we somehow change our config to not break your integration?
https://hg.mozilla.org/projects/nss/rev/d861923a4e5b
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 3.28
You need to log in before you can comment on or make changes to this bug.