[e10s] Extremely slow to open (large (> 30MB) PDF files). And other opened tab is unresponsive

RESOLVED WORKSFORME

Status

()

Firefox
PDF Viewer
RESOLVED WORKSFORME
a year ago
9 months ago

People

(Reporter: David Bourguignon, Unassigned)

Tracking

({multiprocess, perf})

49 Branch
x86_64
Windows 7
multiprocess, perf
Points:
---

Firefox Tracking Flags

(firefox49 wontfix, firefox50 affected, firefox51 affected, firefox52 wontfix)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
Build ID: 20160922113459

Steps to reproduce:

I tried to open the following PDF documents:

http://fondation.cetim.fr/pages/projets/fondationCetim_RecuperationEnergieVibrationsAmbiantes.pdf

http://www.apur.org/sites/default/files/documents/incidences_evolution_loi_ALUR_bati_parisien.pdf


Actual results:

Firefox got stuck for several minutes, and this caused every opened tab to freeze too... Since the whole browser was now useless, my patience ran out and I killed the Firefox process.

Ironically, the very same link, on the very same machine, at the very same moment was handled perfectly by Google Chrome. Each time, I got my PDF file in less than 5 seconds.


Expected results:

Firefox should be designed with any kind of machine configuration (mine is "old": a 2011 Dell high-end laptop) and any kind of files (a 50 MB PDF file is not large by current standards) in mind...

My two cents (I apologize, they are not optimistic): since the switch to the new multi-threaded software architecture, I encounter a lot of usability problems like this. And each time Google Chrome delivers a far better result... This is sad: I need good tools to work with, and Firefox is less and less relevant to my work.

Thanks in advance for your help!
(Reporter)

Updated

a year ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64

Updated

a year ago
Component: Untriaged → PDF Viewer

Comment 1

a year ago
I can reproduce the super slow if e10s mode. And big spinner is spinning for long period when I open other tabs while the pdf is loading.

If disable e10s, it is faster as same as Chrome. And I can open other tabs properly while the pdf is loading.

https://hg.mozilla.org/mozilla-central/rev/99a239e1866a57f987b08dad796528e4ea30e622
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 ID:20161020030211
Status: UNCONFIRMED → NEW
status-firefox49: --- → wontfix
status-firefox50: --- → affected
status-firefox51: --- → affected
status-firefox52: --- → affected
Ever confirmed: true
Keywords: multiprocess, perf

Updated

a year ago
Summary: Firefox cannot handle the download of large (> 30MB) PDF files properly → [e10s] Extremely slow to open (large (> 30MB) PDF files). And other opened tab is unresponsive
Mass wontfix for bugs affecting firefox 52.
status-firefox52: affected → wontfix

Comment 3

9 months ago
Can you still reproduce the issue? Both PDF's seem pretty snappy for me.
Flags: needinfo?(contact)
(Reporter)

Comment 4

9 months ago
Dear Brendan, thanks for your feedback. I confirm that the issue is no longer showing up: the bug seems to have been caught in the meantime... I suggest that we close this report.
Flags: needinfo?(contact)

Updated

9 months ago
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.