Cert Buildbot test on dell R330 intel Hardware running windows 10

RESOLVED FIXED

Status

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: q, Assigned: q)

Tracking

Details

(Whiteboard: [windows])

(Assignee)

Description

2 years ago
t-w1064-ix-0003 is the new dell server setup under an existing name already in buildbot for testing.

The new video chipset is intel based and needs to be checked out.
is this ready for testing?  If so, I will need credentials- I would prefer to hop on manually run a bunch of stuff.  If the goal is buildbot, we need to add it to buildbot so we can schedule jobs on it- I would think a couple of manual tests first would be better.
We're getting alerts like this:
<relengbot> [sns alert] Oct 27 20:00:01 buildbot-master110.bb.releng.scl3.mozilla.com watch_twistd_log.py: Count: 1053 | First instance: 2016-10-27 19:00:04-0700 | Most recent instance: 2016-10-27 19:59:59-0700 | Twistd exception: twisted.cred.error.UnauthorizedLogin - t-w1064-ix-0003.wintest.releng.scl3.mozilla.com 10.26.41.229

The buildbot config doesn't allow it at https://hg.mozilla.org/build/buildbot-configs/file/production/mozilla-tests/production_config.py#l39. Since it's already disabled in slavealloc I've tried closing the command window.
Copying from an email from Milan so that this is captured in bugs.


We want to make sure the hardware+driver combination is not blacklisted for some reason.  Which means running Firefox and checking the about:support <about:support> and seeing D3D11 & D2D1.1 in the graphics section.

I would also run all the tests we have (correctness and performance) to see if something is drastically different form our current setup.  We would not want a great increase in the (graphics) OOM type situations which would slow our tests down a great deal, or make them useless in actually catching errors.  Assuming there is enough of a graphics memory on these cards, that shouldn’t be an issue.  Otherwise, any other problems that may show up in tests are probably an indication we should do something about those failures, rather than change the hardware so that we don’t see them.
And a followup from jmaher


d3d11 looks blacklisted, and I don't see d2d1.1.

I have ran all unittests and talos tests on the box- everything works in general and performs within normal runtimes.

here is the output from about:support:

{
  "application": {
    "name": "Firefox",
    "osVersion": "Windows_NT 10.0",
    "version": "52.0a1",
    "buildID": "20161104035521",
    "userAgent": "Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0",
    "safeMode": false,
    "updateChannel": "default",
    "supportURL": "https://support.mozilla.org/1/firefox/52.0a1/WINNT/en-US/",
    "numTotalWindows": 1,
    "numRemoteWindows": 1,
    "remoteAutoStart": true,
    "autoStartStatus": 1
  },
  "modifiedPreferences": {
    "browser.cache.frecency_experiment": 4,
    "browser.cache.disk.smart_size.first_run": false,
    "browser.cache.disk.capacity": 358400,
    "browser.cache.disk.filesystem_reported": 1,
    "browser.download.importedFromSqlite": true,
    "browser.places.smartBookmarksVersion": 8,
    "browser.startup.homepage_override.buildID": "20161104035521",
    "browser.startup.homepage_override.mstone": "52.0a1",
    "browser.urlbar.lastSuggestionsPromptDate": 20161107,
    "browser.urlbar.daysBeforeHidingSuggestionsPrompt": 3,
    "extensions.lastAppVersion": "52.0a1",
    "media.gmp-manager.buildID": "20161104035521",
    "media.gmp.storage.version.observed": 1,
    "media.gmp-gmpopenh264.lastUpdate": 1478549262,
    "media.gmp-gmpopenh264.version": "1.6",
    "media.hardware-video-decoding.failed": false,
    "media.gmp-gmpopenh264.abi": "x86-msvc-x64",
    "media.gmp-widevinecdm.abi": "x86-msvc-x64",
    "media.gmp-manager.lastCheck": 1478549262,
    "media.gmp-widevinecdm.version": "1.4.8.903",
    "media.gmp-widevinecdm.lastUpdate": 1478549263,
    "network.cookie.prefsMigrated": true,
    "network.predictor.cleaned-up": true,
    "places.history.expiration.transient_current_max_pages": 122334,
    "plugin.disable_full_page_plugin_for_types": "application/pdf",
    "security.sandbox.content.tempDirSuffix": "{04e8639b-89c5-4e73-97b0-f360573307c7}",
    "ui.osk.debug.keyboardDisplayReason": "IKPOS: Touch screen not found."
  },
  "lockedPreferences": {},
  "javaScript": {
    "incrementalGCEnabled": true
  },
  "accessibility": {
    "isActive": false,
    "forceDisabled": 0
  },
  "libraryVersions": {
    "NSPR": {
      "minVersion": "4.13.1",
      "version": "4.13.1"
    },
    "NSS": {
      "minVersion": "3.28 Beta",
      "version": "3.28 Beta"
    },
    "NSSUTIL": {
      "minVersion": "3.28 Beta",
      "version": "3.28 Beta"
    },
    "NSSSSL": {
      "minVersion": "3.28 Beta",
      "version": "3.28 Beta"
    },
    "NSSSMIME": {
      "minVersion": "3.28 Beta",
      "version": "3.28 Beta"
    }
  },
  "userJS": {
    "exists": false
  },
  "crashes": {
    "submitted": [],
    "pending": 0
  },
  "sandbox": {
    "contentSandboxLevel": 2
  },
  "extensions": [
    {
      "name": "Application Update Service Helper",
      "version": "1.0",
      "isActive": true,
      "id": "aushelper@mozilla.org"
    },
    {
      "name": "FlyWeb",
      "version": "1.0.0",
      "isActive": true,
      "id": "flyweb@mozilla.org"
    },
    {
      "name": "Form Autofill",
      "version": "1.0",
      "isActive": true,
      "id": "formautofill@mozilla.org"
    },
    {
      "name": "Multi-process staged rollout",
      "version": "1.5",
      "isActive": true,
      "id": "e10srollout@mozilla.org"
    },
    {
      "name": "Pocket",
      "version": "1.0.5",
      "isActive": true,
      "id": "firefox@getpocket.com"
    },
    {
      "name": "Web Compat",
      "version": "1.0",
      "isActive": true,
      "id": "webcompat@mozilla.org"
    }
  ],
  "experiments": [],
  "graphics": {
    "numTotalWindows": 1,
    "numAcceleratedWindows": 0,
    "windowLayerManagerType": "Basic",
    "windowLayerManagerRemote": true,
    "supportsHardwareH264": "No; Hardware video decoding disabled or blacklisted",
    "currentAudioBackend": "wasapi",
    "numAcceleratedWindowsMessage": [
      "blockedGfxCard"
    ],
    "adapterDescription": "Microsoft Basic Display Adapter",
    "adapterVendorID": "0x102b",
    "adapterDeviceID": "0x0534",
    "adapterSubsysID": "06a61028",
    "adapterRAM": "0",
    "adapterDrivers": "Unknown",
    "driverVersion": "10.0.10240.16384",
    "driverDate": "6-21-2006",
    "adapterDescription2": "",
    "adapterVendorID2": "",
    "adapterDeviceID2": "",
    "adapterSubsysID2": "",
    "adapterRAM2": "",
    "adapterDrivers2": "",
    "driverVersion2": "",
    "driverDate2": "",
    "isGPU2Active": false,
    "direct2DEnabled": false,
    "directWriteEnabled": true,
    "directWriteVersion": "10.0.10240.16430",
    "direct2DEnabledMessage": [
      "blockedGfxCard"
    ],
    "webglRenderer": "Google Inc. -- ANGLE (Microsoft Basic Render Driver Direct3D11 vs_5_0 ps_5_0)",
    "webgl2Renderer": "Google Inc. -- ANGLE (Microsoft Basic Render Driver Direct3D11 vs_5_0 ps_5_0)",
    "info": {
      "AzureCanvasBackend": "skia",
      "AzureCanvasAccelerated": 0,
      "AzureFallbackCanvasBackend": "cairo",
      "AzureContentBackend": "skia",
      "ApzWheelInput": 1,
      "ApzTouchInput": 1
    },
    "featureLog": {
      "features": [
        {
          "name": "HW_COMPOSITING",
          "description": "Compositing",
          "status": "available",
          "log": [
            {
              "type": "default",
              "status": "available"
            }
          ]
        },
        {
          "name": "D3D11_COMPOSITING",
          "description": "Direct3D11 Compositing",
          "status": "blacklisted",
          "log": [
            {
              "type": "default",
              "status": "available"
            },
            {
              "type": "env",
              "status": "blacklisted",
              "message": "#BLOCKLIST_FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR"
            }
          ]
        },
        {
          "name": "D3D9_COMPOSITING",
          "description": "Direct3D9 Compositing",
          "status": "blacklisted",
          "log": [
            {
              "type": "default",
              "status": "disabled",
              "message": "Disabled by default"
            },
            {
              "type": "env",
              "status": "blacklisted",
              "message": "#BLOCKLIST_FEATURE_FAILURE_UNKNOWN_DEVICE_VENDOR"
            }
          ]
        },
        {
          "name": "DIRECT2D",
          "description": "Direct2D",
          "status": "unavailable",
          "log": [
            {
              "type": "default",
              "status": "unavailable",
              "message": "Direct2D requires Direct3D 11 compositing"
            }
          ]
        },
        {
          "name": "D3D11_HW_ANGLE",
          "description": "Direct3D11 hardware ANGLE",
          "status": "disabled",
          "log": [
            {
              "type": "default",
              "status": "unavailable",
              "message": "D3D11 compositing is disabled"
            },
            {
              "type": "env",
              "status": "disabled",
              "message": "D3D11 compositing is disabled"
            }
          ]
        }
      ],
      "fallbacks": []
    },
    "crashGuards": []
  }
}
And the reply from Milan:

This doesn’t look like an Intel card - from about:support <about:support>, it seems to be a Matrox GRE200ER2 - perhaps a chip on the motherboard? In other words, the Intel card is not getting detected?

What’s the actual spec/name/type of the Intel card we’re thinking of getting?
When I talked to Q, he thought this might be a driver issue. He was out at the end of last week, so NI him for any further info he's found.
Flags: needinfo?(q)
According to https://us.icecat.biz/us/p/dell/r330-5775/servers-5397063835775-R330-30371242.html the onboard is a Matrox G200. Q: was there a different video card that should be used for the OS?
(Assignee)

Comment 8

2 years ago
The intel GPU is fronted my a matrox card. This caused us to look into other options currently going to HPE "moonshot" closing bug.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(q)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.